summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-10-02 20:31:26 +0100
committerJustin Lecher <jlec@gentoo.org>2017-10-02 20:31:52 +0100
commit94f68b4448debca63c4a7d98a95aabc16f5a116d (patch)
tree49de1023a6cb2495a610dd6cd68e479a396f660b
parentapp-backup/duply: Version Bump (diff)
downloadgentoo-94f68b44.tar.gz
gentoo-94f68b44.tar.bz2
gentoo-94f68b44.zip
sci-chemistry/pymol-plugins-dynamics: Version Bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/Manifest1
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.1.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-dynamics/Manifest b/sci-chemistry/pymol-plugins-dynamics/Manifest
index 90b61c6d2ce3..9e488a83d199 100644
--- a/sci-chemistry/pymol-plugins-dynamics/Manifest
+++ b/sci-chemistry/pymol-plugins-dynamics/Manifest
@@ -1 +1,2 @@
DIST pymol-plugins-dynamics-2.0.7.tar.gz 822680 SHA256 282e806b088a8d059ff5c722bb1e4789591cc263e9911d9129d3c3863ed4a5e0 SHA512 0d57e3e90a86a59cb96b11371ff1227b2b3e8f5b82cce713f4a855d6e7f5a10524508d4cb4dad7d9f77562fc1753b1af3c9240d4333e0189dabeef07c40d78a1 WHIRLPOOL 51d866d45e172751151f4fd0bfb4d6cb102b0279e0c4a3aff68242a23fbaaaf9dfa347842192c1cef0d182708d6f17c383fc87707e543d9ccec6bc2d8aaa7d9d
+DIST pymol-plugins-dynamics-2.1.1.tar.gz 816623 SHA256 31b7ebca39e4922af9a5d05d7e1e81688ba096e6ed4355291362a7bf94d6f5e9 SHA512 e872c131e7d4ae37bd0e33e56d5d51e83ad732a125a46802ad9fa08648906d49de166bf75fbeca1431726aa9df781671c29578a799f580a94dc1fd89fb398b3c WHIRLPOOL a8396f962bfd0571d09696aa2f1ee73e0da120db70beac6f871fcf971854320b3b07e03e926c192fc137765d0249197fc5ab432e845adbaac8f817245736e866
diff --git a/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.1.1.ebuild b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.1.1.ebuild
new file mode 100644
index 000000000000..a860012cf6ff
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+MY_PN="Dynamics"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular dynamics in Pymol"
+HOMEPAGE="https://github.com/tomaszmakarewicz/Dynamics"
+SRC_URI="https://github.com/tomaszmakarewicz/Dynamics/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sci-chemistry/prody[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( manual.odt )
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_foreach_impl python_domodule pymol_plugin_dynamics.py
+}