summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-01-28 07:14:00 +0000
committerSam James <sam@gentoo.org>2022-01-28 08:36:16 +0000
commit94f76871b61a0733990dffb32796276dca7661f2 (patch)
tree633392a938ae17d0c7731b29bb09ae7aa24b04b1
parentdev-util/clion: remove old version (diff)
downloadgentoo-94f76871.tar.gz
gentoo-94f76871.tar.bz2
gentoo-94f76871.zip
www-apps/gitea: security bump to 1.15.10
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.15.10.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 89fa2fa6367e..e483ad46c05f 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1,3 @@
+DIST gitea-1.15.10.tar.gz 48818877 BLAKE2B 00e2fc8fb0ca5952d96de1b4ed53d0bd6d17b22fc0d7c2aacc313ed74d0a2d268ad714a363c5408daca9b57beaa0305b369d9400019f9c60e133a976f0731076 SHA512 6598e2b8cb84e03370b704f57783612bb4bb938527bbcfcaaf0607035e73e3b480e40ca6fa196ae641ec91483af54688c5acf8dcce59d4ee8c6de9f393a8f531
DIST gitea-1.15.7.tar.gz 48716399 BLAKE2B 4238dad8ce64f205bc18fb35a395b18f6da9f34e5bc0dd9d9bb33d5b8413895fb11f85e8514aca62485ce70f0af5091cb8dfeaccecd146fe5e37ca250227847d SHA512 9488776bb39d15a7390e6734e05c6ee9e092a52055575bc784660d6815125f29498d16a7807dac71ecbabc3f08c407c2da1514c36cce72855a17a9ed7b52fbb9
DIST gitea-1.15.8.tar.gz 48705540 BLAKE2B fe51af1ac573958e615e600925a3e2a8f1bdfe44333304571198de58fa989e8f8c9ebc4f4714d7700c24f28cba60170a2e34c4416ed28ec201577af92d557a82 SHA512 026f8006fa5f51f6bd753228290f1f3714cd5b23c35e2041b309fc4d0d66be9f84fdaf4c7bd5759248fa26e3d3b9fe628fd5ee4c96e13ff6c99fa7facef4ab06
diff --git a/www-apps/gitea/gitea-1.15.10.ebuild b/www-apps/gitea/gitea-1.15.10.ebuild
new file mode 100644
index 000000000000..eaeda1a3f382
--- /dev/null
+++ b/www-apps/gitea/gitea-1.15.10.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2016-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct pam sqlite"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ DRONE_TAG="${PV}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ TAGS="${gitea_tags[*]}"
+ )
+
+ env "${makeenv[@]}" emake backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process gitea.conf
+
+ ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
+ ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
+ ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
+}