summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-03 06:21:28 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-03 06:47:54 -0700
commit94fc4c2aa51e6a1cc889cb7b86ff73ca0991032a (patch)
treed2da95153b1b9f96b9418bf5633052c8efb058bb
parentgui-libs/amtk: Version bump to 5.4.0 (diff)
downloadgentoo-94fc4c2aa51e6a1cc889cb7b86ff73ca0991032a.tar.gz
gentoo-94fc4c2aa51e6a1cc889cb7b86ff73ca0991032a.tar.bz2
gentoo-94fc4c2aa51e6a1cc889cb7b86ff73ca0991032a.zip
gui-libs/tepl: Version bump to 6.0.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gui-libs/tepl/Manifest1
-rw-r--r--gui-libs/tepl/tepl-6.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
index dee48e274835..39ca7fb9fe22 100644
--- a/gui-libs/tepl/Manifest
+++ b/gui-libs/tepl/Manifest
@@ -1,2 +1,3 @@
DIST tepl-5.0.1.tar.xz 126068 BLAKE2B 2c3038326660f6326c5030cb944f8cee885b794a481f6d8f1b5d87a8ea7121ded381d28b36246a99b57bbea5fd9e6d2d4f65f9dfc54d8154ee8aabbccd7e3cb5 SHA512 f363d182185976447d235cf1201148e5201cdabd1fa8b88d7a763a965896f87bd222a0161c11e93662afaf4e474bbd0308643d28559aadc27b9d48974f4c458d
+DIST tepl-6.0.1.tar.xz 142884 BLAKE2B 7da51ecd3b1a74fc22e98020ad6b73c98524c97384c26c9cc0ef0a972214afcbb8c2bd4976904cea91784f815e626c501cf68d85d876b764af3b8bd182848694 SHA512 31d7a6e5f66e66f380f780089c13ccb938052237acf514713a731b374afd6871fb8d0685db2137fa2c62548dd3ae85a198ce3bfc3148ec30feb0cb0f10c78114
DIST tepl-6.00.0.tar.xz 141908 BLAKE2B 200693a8cf760d18e1c53647abb8156f7e067557b4cefbd05b03c5a3ec83c3c5807ab93e0464178b68fc9f2572c3175fbf9355f4131df1fe7f79b5e2deb3961e SHA512 e36877b9f33943715a50546d82ed61e65fc07b71dca2c85ff350a305767e96eda74dc14f30b2a430e14deacd4ee8d49697fe01df1f5023afab3747e5e9c95e2e
diff --git a/gui-libs/tepl/tepl-6.0.1.ebuild b/gui-libs/tepl/tepl-6.0.1.ebuild
new file mode 100644
index 000000000000..f04c466fe49c
--- /dev/null
+++ b/gui-libs/tepl/tepl-6.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tepl https://gitlab.gnome.org/swilmet/tepl"
+
+LICENSE="LGPL-3+"
+SLOT="6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection gtk-doc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection gobject_introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}