summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-15 04:53:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-15 05:10:05 +0100
commit94ff14077865b66394f2be05aea2ec9f7b2fe449 (patch)
tree4a1b155a119db43a0e2570d048e24c1d3d20c89c
parentdev-python/Faker: Bump to 23.2.0 (diff)
downloadgentoo-94ff14077865b66394f2be05aea2ec9f7b2fe449.tar.gz
gentoo-94ff14077865b66394f2be05aea2ec9f7b2fe449.tar.bz2
gentoo-94ff14077865b66394f2be05aea2ec9f7b2fe449.zip
dev-python/jupyterlab-server: Bump to 2.25.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.25.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index 39337298c31f..d07fa4ea1a24 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1 +1,2 @@
DIST jupyterlab_server-2.25.2.tar.gz 74028 BLAKE2B 6dffdea7c002fee946a8af728592ea2404f4568bdfaae1727da5c3725edb284a7ad8594efdf71a4671249a4164878288bcb4aa588a59f45fa83fbda0656db89b SHA512 6270505170e7586fae8c4f7fcabaed6e2ef2068ec35bc5eb630e1b5177aab24d8e8be4755ad6dd3f97c5e3a1aa6c770f554efe92a2db5a5bfe99bf420e2b5a34
+DIST jupyterlab_server-2.25.3.tar.gz 74625 BLAKE2B 28fe6d85ed82b44e3968da3abe5ac2e5559b0527943eaeca3e3351610198feb00337ec6877a0a495a3a3f8c78a378dd44ce6941f2c9d5e34d655ccdf60c96dbd SHA512 62c1f1d51c588a64c6dea70dc888006b026b451ccc26331183f4878c9e1cc6b6631ba63ea6402265bdf97f85343f6762d16d82b37d666a6d9d8e8833b91457d2
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.25.3.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.25.3.ebuild
new file mode 100644
index 000000000000..023800f2076e
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.25.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.19[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.18[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.8[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin -p timeout
+}