summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-25 06:39:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-25 07:20:28 +0200
commit9504275bcd190f0bb4d13e909109fdb51c6d2a8e (patch)
tree295e876d763afee7f7c8c8354e45ea63039b17d2
parentdev-python/pydantic-core: Bump to 2.4.0 (diff)
downloadgentoo-9504275b.tar.gz
gentoo-9504275b.tar.bz2
gentoo-9504275b.zip
dev-python/editables: Bump to 0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/editables/Manifest1
-rw-r--r--dev-python/editables/editables-0.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/editables/Manifest b/dev-python/editables/Manifest
index d2582ac082d0..31b4cfa249e9 100644
--- a/dev-python/editables/Manifest
+++ b/dev-python/editables/Manifest
@@ -1,2 +1,3 @@
DIST editables-0.3.gh.tar.gz 12493 BLAKE2B 95e05e7553efa4856ee5bde2c18a2566f1e65318bfc46c8ecd732f4d6b42f10ce54cc3aecc4d53bcfc627e6938c4155d48a39ced5f64395dbafb9187cb009e4f SHA512 493f20d1e6b39f8ed6668adc208723d447a31ae3c3087f7db9a9a0de617958e8afebd3b3a1836638f749fb0ec911e51256b727deb4c0ce08327356238df0a3f3
DIST editables-0.4.gh.tar.gz 15248 BLAKE2B 331686fb4e4f912f88c7565ffe4788adbd738be779a9d0c18b786f3fc81f7429fc71050c65afb324f482fb6a12cec512eec99f6eb30b770e297f512c5496ba78 SHA512 59c72544198668d6022a133a0e7a8f559ba23e618a0359c810dde2665177224704d409fac973d05869215007f118faaa7678e7ef83b7f44b50a5e283b26eec92
+DIST editables-0.5.gh.tar.gz 15469 BLAKE2B 9bbbc61a4e0a57edc6b7ba463da0d6c2f40090e347e67f203f16163bec70b63a2289332e9d69a46919f8aa009be1ec96e1b1cd2708ce5eb6ab33af6eb36360e0 SHA512 ac39d2e6a51625697c517b85fec11b525b1a41f82cf4f55c7595fed19da867065a62eee5e3656706f7402d0499754f4a142da77d699c59dffc8b769fa1c3dbe2
diff --git a/dev-python/editables/editables-0.5.ebuild b/dev-python/editables/editables-0.5.ebuild
new file mode 100644
index 000000000000..8423d6038aee
--- /dev/null
+++ b/dev-python/editables/editables-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for creating 'editable wheels'"
+HOMEPAGE="
+ https://pypi.org/project/editables/
+ https://github.com/pfmoore/editables/
+"
+SRC_URI="
+ https://github.com/pfmoore/editables/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest