summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-10 14:47:57 +0000
committerSam James <sam@gentoo.org>2024-03-10 14:47:57 +0000
commit950545a7b4d0a4b099a775ee1116aa7c70a9ca35 (patch)
treeb7c54574651c5f4a693de793a90d2dc0b94f6c7b
parentmedia-libs/openjpeg: drop stale CMake arg for pkgconfig files (diff)
downloadgentoo-950545a7b4d0a4b099a775ee1116aa7c70a9ca35.tar.gz
gentoo-950545a7b4d0a4b099a775ee1116aa7c70a9ca35.tar.bz2
gentoo-950545a7b4d0a4b099a775ee1116aa7c70a9ca35.zip
sys-cluster/rdma-core: drop 47.0-r1, 48.0
Closes: https://bugs.gentoo.org/898734 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/rdma-core/Manifest2
-rw-r--r--sys-cluster/rdma-core/rdma-core-47.0-r1.ebuild111
-rw-r--r--sys-cluster/rdma-core/rdma-core-48.0.ebuild119
3 files changed, 0 insertions, 232 deletions
diff --git a/sys-cluster/rdma-core/Manifest b/sys-cluster/rdma-core/Manifest
index e6a3a8d81fa4..b388e23bba57 100644
--- a/sys-cluster/rdma-core/Manifest
+++ b/sys-cluster/rdma-core/Manifest
@@ -1,3 +1 @@
-DIST rdma-core-47.0.tar.gz 1945228 BLAKE2B 1a1342b7166816e220849d854f551097d364173f3db95f300eed4ff416a82cfaf335ac1cbe1da6b8c1b2213b9a6cd3a476fa7ff9a266248ab40d17b21b04417e SHA512 6de17576f27204ed3e3a4a386ecd5ca20bbef4f23b16cdeacb362457db652ee790e1b1aab46499393908994f40c79e8d184ceb9995b29bc5c9ad22170d599f2e
-DIST rdma-core-48.0.tar.gz 1955938 BLAKE2B 18e32486af2a88c3d3fdd3c0bb90b7f1d713a83c6027c330f71aed47ada4dec30b4840d1a35eee5d1d8745ca0d63ee1612b21454ed61265e0076485868b100f7 SHA512 48303d830e83d4fb6a88e23764380872dadc4579e8a1a62275447fe4a6613aea9ac08876e4a58f5799af9455e6dabbced8bc8e1663812fe68a2d642a1152b195
DIST rdma-core-50.0.tar.gz 1961247 BLAKE2B e17857eae1cebea7f82d061a41905577088c553f18f7aacfc7901e13e890a0b5bb2a776140e603b41c8a45d6690e27852f291bd0cc0b839c469c2caeb0854bb3 SHA512 0d341300dde2a8756ab0e80bf8d316627c997e85661d50b51897aa03e1b7326f4ca7a6f24e370354779482a2d9455e58dbb07e6292ed8b511e7f195e4e2d1850
diff --git a/sys-cluster/rdma-core/rdma-core-47.0-r1.ebuild b/sys-cluster/rdma-core/rdma-core-47.0-r1.ebuild
deleted file mode 100644
index 43015470a799..000000000000
--- a/sys-cluster/rdma-core/rdma-core-47.0-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake perl-functions python-single-r1 udev systemd
-
-DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
-HOMEPAGE="https://github.com/linux-rdma/rdma-core"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
-else
- SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
-SLOT="0"
-IUSE="neigh python static-libs systemd valgrind"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="
- dev-lang/perl:=
- virtual/libudev:=
- neigh? ( dev-libs/libnl:3 )
- systemd? ( sys-apps/systemd:= )
- valgrind? ( dev-debug/valgrind )
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="
- ${COMMON_DEPEND}
- python? (
- $(python_gen_cond_dep '
- <dev-python/cython-3[${PYTHON_USEDEP}]
- ')
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-fabric/infiniband-diags
- !sys-fabric/libibverbs
- !sys-fabric/librdmacm
- !sys-fabric/libibumad
- !sys-fabric/ibacm
- !sys-fabric/libibmad
- !sys-fabric/srptools
- !sys-fabric/infinipath-psm
- !sys-fabric/libcxgb3
- !sys-fabric/libcxgb4
- !sys-fabric/libmthca
- !sys-fabric/libmlx4
- !sys-fabric/libmlx5
- !sys-fabric/libocrdma
- !sys-fabric/libnes
-"
-# python is required unconditionally at build-time
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch
-)
-
-src_configure() {
- perl_set_version
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_RUNDIR=/run
- -DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
- -DCMAKE_INSTALL_PERLDIR="${VENDOR_LIB}"
- -DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
- -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
- -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
- -DENABLE_VALGRIND="$(usex valgrind)"
- -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
- -DENABLE_STATIC="$(usex static-libs)"
- -DNO_PYVERBS="$(usex !python)"
- -DNO_MAN_PAGES=1
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- udev_dorules "${ED}"/usr/share/doc/${PF}/70-persistent-ipoib.rules
-
- if use neigh; then
- newinitd "${FILESDIR}"/ibacm.init ibacm
- newinitd "${FILESDIR}"/iwpmd.init iwpmd
- fi
-
- newinitd "${FILESDIR}"/srpd.init srpd
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/sys-cluster/rdma-core/rdma-core-48.0.ebuild b/sys-cluster/rdma-core/rdma-core-48.0.ebuild
deleted file mode 100644
index 1b54ae21ed5d..000000000000
--- a/sys-cluster/rdma-core/rdma-core-48.0.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit cmake perl-functions python-single-r1 udev systemd
-
-DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
-HOMEPAGE="https://github.com/linux-rdma/rdma-core"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
-else
- SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
-SLOT="0"
-IUSE="lttng neigh python static-libs systemd valgrind"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="
- dev-lang/perl:=
- virtual/libudev:=
- lttng? ( dev-util/lttng-ust:= )
- neigh? ( dev-libs/libnl:3 )
- systemd? ( sys-apps/systemd:= )
- valgrind? ( dev-debug/valgrind )
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="
- ${COMMON_DEPEND}
- python? (
- $(python_gen_cond_dep '
- <dev-python/cython-3[${PYTHON_USEDEP}]
- ')
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-fabric/infiniband-diags
- !sys-fabric/libibverbs
- !sys-fabric/librdmacm
- !sys-fabric/libibumad
- !sys-fabric/ibacm
- !sys-fabric/libibmad
- !sys-fabric/srptools
- !sys-fabric/infinipath-psm
- !sys-fabric/libcxgb3
- !sys-fabric/libcxgb4
- !sys-fabric/libmthca
- !sys-fabric/libmlx4
- !sys-fabric/libmlx5
- !sys-fabric/libocrdma
- !sys-fabric/libnes
-"
-# python is required unconditionally at build-time
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch
-)
-
-src_prepare() {
- # DEFINED is true even if the value is false, which makes lttng unconditional
- sed -i -e 's/if (DEFINED ENABLE_LTTNG)/if (ENABLE_LTTNG)/' CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- perl_set_version
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_RUNDIR=/run
- -DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
- -DCMAKE_INSTALL_PERLDIR="${VENDOR_LIB}"
- -DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
- -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
- -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
- -DENABLE_LTTNG="$(usex lttng)"
- -DENABLE_VALGRIND="$(usex valgrind)"
- -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
- -DENABLE_STATIC="$(usex static-libs)"
- -DNO_PYVERBS="$(usex !python)"
- -DNO_MAN_PAGES=1
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- udev_dorules "${ED}"/usr/share/doc/${PF}/70-persistent-ipoib.rules
-
- if use neigh; then
- newinitd "${FILESDIR}"/ibacm.init ibacm
- newinitd "${FILESDIR}"/iwpmd.init iwpmd
- fi
-
- newinitd "${FILESDIR}"/srpd.init srpd
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}