summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-02-18 14:59:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-02-18 15:00:08 +0100
commit9523b20c27d12dd72d1fd5ced3ba4995099925a2 (patch)
treed7d3b1b28750334fb71fd3538dbb152cec8dc09c
parentapp-editors/nano: Bump to version 6.2 (diff)
downloadgentoo-9523b20c.tar.gz
gentoo-9523b20c.tar.bz2
gentoo-9523b20c.zip
app-editors/nano: Removed old
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-6.0.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index cf70eff42a3e..296b2fe990c5 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,4 +1,3 @@
DIST nano-5.9.tar.gz 3093675 BLAKE2B d4fa2f0e64b6ab243a2b127ff894e900098f6261f5d46657ff3459cc0b51683a63fc5de54bd4545b47bc16c633b09142f8501b84a09df3e8123da5233a063766 SHA512 61bf4de300579bc6f0028a2237e105228d8657819c02f32c7ef8f84f9c54734df8fb9a9cddbce0f7721ebc5ac8ae4799c118291ae15480082f8b1317019a485d
-DIST nano-6.0.tar.gz 3114631 BLAKE2B d89abcbd3673867447bbfd4eedfcd7b7d5250a3ebc1048068cf03f690b2fbd072c0224c00bef9b829bff8343dacf669e8e784fa24dafaa6441746471b692c55a SHA512 fa5726810cfb53fd2cc451d5a34e8f5c316c496f8d649a3899fae0b61cc5ca0bffd28deb780e4e0c98169487b8c34468fd401534b9110ba968d2d4ab6847bc87
DIST nano-6.1.tar.gz 3146292 BLAKE2B ade773182d12b6d6452c23896e564a097d850630c87b0af622fe7766931aa2e5ef5e9d868e521e46e029851cdd428cd60b6c3e95bdb28df0733cba8b432f202a SHA512 e034c9d7c96bf6d7ac22a2188fccf87693dd5d19ddbcfb907f817544fb2ddfce2ee9331842d885870718617ea4fd0c9151f62b3e8dc52a486cec9a30e84539c0
DIST nano-6.2.tar.gz 3146876 BLAKE2B be6dbc1f53890764184a701e97e792762600c892933830bfcb5c2c4eab19d659583fe797d7197c9045ea8912215aa5885a05f02c66194df17253d6788e0ba599 SHA512 5a59906664a88a03f215d8dba8f7e481fbaffc7bdf93c89ca997df7a8aba2cbb4d45ac84d11f03a796488b82b01ca75161a5ab49fd9115661575451b6ab018c4
diff --git a/app-editors/nano/nano-6.0.ebuild b/app-editors/nano/nano-6.0.ebuild
deleted file mode 100644
index ad20434b2ed1..000000000000
--- a/app-editors/nano/nano-6.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
- inherit git-r3 autotools
-else
- MY_P="${PN}-${PV/_}"
- SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="debug justify magic minimal ncurses nls +spell +split-usr static unicode"
-
-LIB_DEPEND="
- >=sys-libs/ncurses-5.9-r1:=[unicode(+)?]
- sys-libs/ncurses:=[static-libs(+)]
- magic? ( sys-apps/file[static-libs(+)] )
- nls? ( virtual/libintl )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-REQUIRED_USE="
- magic? ( !minimal )
-"
-
-src_prepare() {
- default
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --htmldir=/trash
- $(use_enable !minimal color)
- $(use_enable !minimal multibuffer)
- $(use_enable !minimal nanorc)
- $(use_enable magic libmagic)
- $(use_enable spell speller)
- $(use_enable justify)
- $(use_enable debug)
- $(use_enable nls)
- $(use_enable unicode utf8)
- $(use_enable minimal tiny)
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- # don't use "${ED}" here or things break (#654534)
- rm -r "${D}"/trash || die
-
- dodoc doc/sample.nanorc
- docinto html
- dodoc doc/faq.html
- insinto /etc
- newins doc/sample.nanorc nanorc
- if ! use minimal ; then
- # Enable colorization by default.
- sed -i \
- -e '/^# include /s:# *::' \
- "${ED}"/etc/nanorc || die
-
- # Since nano-5.0 these are no longer being "enabled" by default
- # (bug #736848)
- local rcdir="/usr/share/nano"
- mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
- rmdir "${ED}"${rcdir}/extra || die
-
- insinto "${rcdir}"
- doins "${FILESDIR}/gentoo.nanorc"
- fi
-
- use split-usr && dosym ../../bin/nano /usr/bin/nano
-}