summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-08 05:00:14 +0000
committerSam James <sam@gentoo.org>2021-12-08 05:00:14 +0000
commit952a29c6138d6eb1e1e3bd77781c053837924d5b (patch)
tree7a1199c7a8f00585ce796bbefdde230056553bbe
parentsci-libs/geos: Stabilize 3.10.0 arm, #828397 (diff)
downloadgentoo-952a29c6138d6eb1e1e3bd77781c053837924d5b.tar.gz
gentoo-952a29c6138d6eb1e1e3bd77781c053837924d5b.tar.bz2
gentoo-952a29c6138d6eb1e1e3bd77781c053837924d5b.zip
media-libs/glm: fix test-core_func_integer test
Note that glm is a header-only library and the miscompilation/unintended optimisation/whatever we want to call it only affectes tests, so no need to revbump (no change in runtime behaviour). See: https://github.com/g-truc/glm/pull/1087 Bug: https://bugs.gentoo.org/818235 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/glm/glm-0.9.9.8-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-libs/glm/glm-0.9.9.8-r1.ebuild b/media-libs/glm/glm-0.9.9.8-r1.ebuild
index 04922fcc2113..744910fd87c9 100644
--- a/media-libs/glm/glm-0.9.9.8-r1.ebuild
+++ b/media-libs/glm/glm-0.9.9.8-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="OpenGL Mathematics"
HOMEPAGE="http://glm.g-truc.net/"
@@ -24,6 +24,10 @@ PATCHES=(
src_configure() {
# Header-only library
if use test; then
+ # See https://github.com/g-truc/glm/pull/1087
+ # https://bugs.gentoo.org/818235
+ append-cxxflags -fno-ipa-modref
+
local mycmakeargs=(
-DGLM_TEST_ENABLE=ON
-DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"