summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 16:48:12 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 16:48:12 +0100
commit9531ad5dc3f2bc8208b00a36e57584e740245705 (patch)
treec8711d22be4fb1fdf56351003a1255506e33a95f
parentdev-libs/concurrencykit: drop old version (diff)
downloadgentoo-9531ad5d.tar.gz
gentoo-9531ad5d.tar.bz2
gentoo-9531ad5d.zip
dev-lua/LuaBitOp: update ebuild
Updated ebuild not to use clean. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild
new file mode 100644
index 000000000000..66c4e3131492
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..2} )
+
+inherit lua multilib-minimal toolchain-funcs
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( "doc/." )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+ lua_foreach_impl multilib_copy_sources
+}
+
+lua_multilib_src_compile() {
+ pushd "${WORKDIR}/${P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CCOPT="
+ "INCLUDES=$(lua_get_CFLAGS)"
+ )
+
+ emake "${myemakeargs[@]}" all
+
+ popd
+}
+
+multilib_src_compile() {
+ lua_foreach_impl lua_multilib_src_compile
+}
+
+lua_multilib_src_test() {
+ pushd "${WORKDIR}/${P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
+
+ local mytests=(
+ "bitbench.lua"
+ "bittest.lua"
+ "md5test.lua"
+ "nsievebits.lua"
+ )
+
+ for mytest in ${mytests[@]}; do
+ LUA_CPATH="./?.so" ${ELUA} ${mytest}
+ done
+
+ popd
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && lua_foreach_impl lua_multilib_src_test
+}
+
+lua_multilib_src_install() {
+ pushd "${WORKDIR}/${P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
+
+ exeinto $(lua_get_cmod_dir)
+ doexe bit.so
+
+ popd
+}
+
+multilib_src_install() {
+ lua_foreach_impl lua_multilib_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}