summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-16 15:14:32 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-16 14:19:12 -0400
commit95486bd9826e4a78a640b966dcc0048372d37174 (patch)
treeef9a3f4730408378ea0641bbdd1f7b97aed32cac
parentsci-geosciences/gnome-maps: Version bump to 45.0 (diff)
downloadgentoo-95486bd9.tar.gz
gentoo-95486bd9.tar.bz2
gentoo-95486bd9.zip
dev-libs/json-glib: Version bump to 1.8.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32847 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/json-glib/Manifest1
-rw-r--r--dev-libs/json-glib/json-glib-1.8.0.ebuild65
-rw-r--r--dev-libs/json-glib/metadata.xml3
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/json-glib/Manifest b/dev-libs/json-glib/Manifest
index 512f29b5a12e..09e85bb0bbdd 100644
--- a/dev-libs/json-glib/Manifest
+++ b/dev-libs/json-glib/Manifest
@@ -1 +1,2 @@
DIST json-glib-1.6.6.tar.xz 1306232 BLAKE2B 93814dad74ef61ef265e348e9e145ceb63c950f1e9ecda23fbaad24e291a1cbfc690e287ccc8959fd7c056634f80815ef54fa2c75b09ebd3e158f3fa4df1c8e7 SHA512 b9a737e4ba3ecdfb9cb8f5fb751cc74e5b1553664d3088c44a1f9e5396d4037958af214dcd290ddf5af98088f46167e10e371e134e1de5cbb7aec84c5c0fd017
+DIST json-glib-1.8.0.tar.xz 157300 BLAKE2B eef0344c353bb9288efb700a6041342379627b924a042263e011f21140166b57b108f6816e80ac692159b49943f9c1afeb722efafa34e8c60f2fcdf53a0dc034 SHA512 e4fe16bb7c5b72fcf9c0966ac1903ff0cd74ec8eab891db4b94e92353bdcb57b24613b6c2cce7bfa1996603c367d1b4939c12209369dfb915aac0f3804a3a900
diff --git a/dev-libs/json-glib/json-glib-1.8.0.ebuild b/dev-libs/json-glib/json-glib-1.8.0.ebuild
new file mode 100644
index 000000000000..08ef50b661fc
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-1.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
+HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="gtk-doc +introspection nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.54.0:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}"
+# TODO: Can we use a newer docbook-xml-dtd, or is one needed at all?
+BDEPEND="
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_environment_reset
+ default
+
+ # Disable installed-tests; this also indirectly removes
+ # build_aux/gen-installed-test.py calls, thus not needing
+ # python-any-r1.eclass
+ sed -e 's/install: true/install: false/g' -i json-glib/tests/meson.build || die
+ sed -e '/install_data/d' -i json-glib/tests/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature gtk-doc gtk_doc)
+ $(meson_native_true man)
+
+ $(meson_feature nls)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use gtk-doc ; then
+ # Move to location that <devhelp-41 will see, reconsider once devhelp-41 is stable
+ mkdir -p "${ED}"/usr/share/gtk-doc/html || die
+ mv "${ED}"/usr/share/doc/json-glib-1.0 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}
diff --git a/dev-libs/json-glib/metadata.xml b/dev-libs/json-glib/metadata.xml
index a753ac3849a1..489464083a6c 100644
--- a/dev-libs/json-glib/metadata.xml
+++ b/dev-libs/json-glib/metadata.xml
@@ -24,6 +24,9 @@
classes for direct serialization into, and deserialization from, JSON data
streams.
</longdescription>
+ <use>
+ <flag name="nls">Enable native language support (translations)</flag>
+ </use>
<upstream>
<remote-id type="gnome-gitlab">GNOME/json-glib</remote-id>
</upstream>