summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:54:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:22 +0200
commit9573d01e4899900f7608ffc6f67da1aea0e8754d (patch)
tree442a68b1929e88809190c39d52ef27198347576c
parentdev-ros/std_srvs: Initial import. Ebuild by me. (diff)
downloadgentoo-9573d01e4899900f7608ffc6f67da1aea0e8754d.tar.gz
gentoo-9573d01e4899900f7608ffc6f67da1aea0e8754d.tar.bz2
gentoo-9573d01e4899900f7608ffc6f67da1aea0e8754d.zip
dev-ros/rosgraph: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/rosgraph/Manifest1
-rw-r--r--dev-ros/rosgraph/metadata.xml5
-rw-r--r--dev-ros/rosgraph/rosgraph-1.11.14.ebuild23
-rw-r--r--dev-ros/rosgraph/rosgraph-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/Manifest b/dev-ros/rosgraph/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/rosgraph/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/rosgraph/metadata.xml b/dev-ros/rosgraph/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosgraph/rosgraph-1.11.14.ebuild b/dev-ros/rosgraph/rosgraph-1.11.14.ebuild
new file mode 100644
index 000000000000..d7e60b429158
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.11.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/rosgraph/rosgraph-9999.ebuild b/dev-ros/rosgraph/rosgraph-9999.ebuild
new file mode 100644
index 000000000000..b4d40e484bf3
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"