summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-02-26 09:30:02 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-02-26 09:30:02 +0100
commit95781b13e394bd620d54022c6163d8661a630bb3 (patch)
treeaea8659509b1a88ab72294ecaddc9c912552be15
parentdev-libs/boehm-gc: bump up to 8.0.2, bug #678800 (diff)
downloadgentoo-95781b13.tar.gz
gentoo-95781b13.tar.bz2
gentoo-95781b13.zip
net-print/hplip-plugin: Version bump to 3.19.1
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.19.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 3d983011be30..feb628e6bffa 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.18.12-plugin.run 10486821 BLAKE2B e48940b1b5fe94dc216383b63bee7807bce9ad265b7c454c201c0ed22ec1964e6c5adf653c3c230789c042cffaaf50bd604bae6f66f407a85f98248934307158 SHA512 82b90aa8245f787e088a1bebfa7892a7f2b97fd04b3702c46eed27306640e562aeec63b4b5b45c24943abe4672f2627d1821bdcdf58a5c1ac4e1d06c7270535f
DIST hplip-3.18.6-plugin.run 2065663 BLAKE2B 501a37dd504250225ddad9712259e0e1b564aa034e433f24d277c5609fa95580417da1a0ae040a4624ff48806a3b34ec56ff31aed843e9f0f0b68b304d2ebd9e SHA512 7b5eb2f43dd014df25ccd9e72dd7efc069db47921f2de650b2ff993dbee60056063edeee6593be7d35019212daf623fff9696b13508a808db92128f5c81bde76
+DIST hplip-3.19.1-plugin.run 11502855 BLAKE2B 715f8927d08e6328a5049b2336b693cfd604703451f558237d45a4955745377a8142ddd56dffeca81e3878425861463b4c1cbfe88dc92a9f024f4681d46712af SHA512 0464728ccaf48755132969a7cfedefeb66b87c9e234249ca4801e5e99a1e34e45e07c9f3486b527a65c320a4cab801f48b5f0f4dce98c40c844dd1ef092d299c
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.1.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.1.ebuild
new file mode 100644
index 000000000000..7714ffa082db
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.19.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+#SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}