summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-14 14:05:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-18 14:09:04 +0200
commit95811d5b5d1d46289f05c53a2299fe0a4f99a152 (patch)
tree5b119187630228ac6d73288a7b5050e3f21c15c1
parentprofiles: hppa,m68k,s390: Mask keyring where gnome-keyring was masked (diff)
downloadgentoo-95811d5b5d1d46289f05c53a2299fe0a4f99a152.tar.gz
gentoo-95811d5b5d1d46289f05c53a2299fe0a4f99a152.tar.bz2
gentoo-95811d5b5d1d46289f05c53a2299fe0a4f99a152.zip
dev-libs/qtkeychain: Rename USE=gnome-keyring -> keyring
Bug: https://bugs.gentoo.org/829730 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild b/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild
index c8d2c178448a..805cd6368bd5 100644
--- a/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild
+++ b/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,20 +18,18 @@ fi
LICENSE="BSD-2"
SLOT="0/1"
-IUSE="gnome-keyring"
+IUSE="keyring"
DEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
- gnome-keyring? (
+ keyring? (
app-crypt/libsecret
dev-libs/glib:2
)
"
RDEPEND="${DEPEND}"
-BDEPEND="
- dev-qt/linguist-tools:5
-"
+BDEPEND="dev-qt/linguist-tools:5"
DOCS=( ChangeLog ReadMe.md )
@@ -40,7 +38,7 @@ src_configure() {
-DBUILD_WITH_QT6=OFF
-DBUILD_TEST_APPLICATION=OFF
-DBUILD_TRANSLATIONS=ON
- -DLIBSECRET_SUPPORT=$(usex gnome-keyring)
+ -DLIBSECRET_SUPPORT=$(usex keyring)
)
cmake_src_configure