summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-03 06:17:23 +0000
committerSam James <sam@gentoo.org>2022-11-03 06:17:23 +0000
commit959bab4fcb8b5d86a17c163f3b341f14612f8c12 (patch)
treefe6f2ff698de520d7ecc9b11fd399a7abe6f18ef
parentmedia-libs/lcms: unconditionally enable threads (diff)
downloadgentoo-959bab4f.tar.gz
gentoo-959bab4f.tar.bz2
gentoo-959bab4f.zip
games-strategy/warzone2100: drop 4.2.6
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-strategy/warzone2100/Manifest1
-rw-r--r--games-strategy/warzone2100/warzone2100-4.2.6.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/games-strategy/warzone2100/Manifest b/games-strategy/warzone2100/Manifest
index 33c85003c01e..6a3badd9f823 100644
--- a/games-strategy/warzone2100/Manifest
+++ b/games-strategy/warzone2100/Manifest
@@ -1,3 +1,2 @@
-DIST warzone2100-4.2.6.tar.xz 338691628 BLAKE2B 234d78feb1fceb0eff23c2c1b8d85a5fd9e5ef8912b324ae159ffdb43be728d6e4aa78bdf01561e60c64826083936bc36c2dfd1cee443aed06a52eaa047e8517 SHA512 5cddeff5b66d9e710b0c4d6d2863100106a901c17815220b7a97633a3980be41eaa192921d39bffff60f547fb5f5358fa1e63a54f41b5083203916314bb3d2a1
DIST warzone2100-4.2.7.tar.xz 338687576 BLAKE2B b504f8ed6b5c1b040b4368429394b7f077c279979ef7847734eeb333512fc374799c73119924fba206a6fc925db54697569a756e113d0a322dd46768c80d0b72 SHA512 af538f3bdf6ec543e5f919377c95c35c730fa6efa5c3ea8d140347595dd9f8056677d4b494677ea20c98da305e0fb588cdb00a3da1c497f96edc58ca8772e45b
DIST warzone2100-videos-2.2.wz 571937134 BLAKE2B 60b70a71bd920e2d72ded5d519b17db2f3db4b0289edadeb58059a21aba7038b95219dc44cb807754461d1a9bdca60f0d7698be68622b8bd64a55efa949622d3 SHA512 ca1a1af51296afdaca137114821508c5783f077090e665eae0f6df895855f57c43f84434706309e819417f5f35d1c649bd14e96dc9fbbb1252d30a4f9a223cf6
diff --git a/games-strategy/warzone2100/warzone2100-4.2.6.ebuild b/games-strategy/warzone2100/warzone2100-4.2.6.ebuild
deleted file mode 100644
index c52979b65465..000000000000
--- a/games-strategy/warzone2100/warzone2100-4.2.6.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PLOCALES="af_ZA bg_BG ca_ES cs da de el en_GB eo es et_EE fa_IR fi fr fy ga he_IL hr hu id_ID id it ko la lt nb nl pl pt_BR pt ro ru sk sl tr tt_RU uk_UA zh_CN zh_TW"
-inherit cmake plocale xdg
-
-MY_PV=$(ver_cut 1-2)
-VIDEOS_PV=2.2
-VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
-DESCRIPTION="3D real-time strategy game"
-HOMEPAGE="https://wz2100.net/"
-SRC_URI="mirror://sourceforge/warzone2100/releases/${PV}/${PN}_src.tar.xz -> ${P}.tar.xz
- videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain vulkan? ( GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Upstream requested debug support
-IUSE="debug discord nls videos vulkan"
-
-CDEPEND="
- >=dev-games/physfs-2[zip]
- dev-db/sqlite:3
- >=dev-libs/libsodium-1.0.14:=
- media-libs/freetype:2
- media-libs/harfbuzz:=
- media-libs/libogg
- media-libs/libpng:=
- media-libs/libsdl2[opengl,video,X]
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/openal
- net-libs/miniupnpc:=
- net-misc/curl
- sys-libs/zlib
- nls? ( virtual/libintl )
- vulkan? ( media-libs/libsdl2:=[vulkan] )
-"
-DEPEND="
- ${CDEPEND}
- dev-libs/fribidi
- media-libs/fontconfig
-"
-RDEPEND="
- ${CDEPEND}
- media-fonts/dejavu
-"
-BDEPEND="
- app-arch/zip
- app-text/asciidoc
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-HTML_DOCS=( doc/quickstartguide.html doc/docbook-xsl.css doc/ScriptingManual.htm )
-DOCS=( README.md doc/images doc/Scripting.md doc/js-globals.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.1.3-no-compress-manpages.patch
-)
-
-src_unpack() {
- unpack ${P}.tar.xz
-}
-
-src_prepare() {
- sed -i -e 's/#top_builddir/top_builddir/' po/Makevars || die
-
- # Delete translations we're not using
- cleanup_po() {
- local locale=${1}
- einfo "Cleaning up disabled locale: ${locale}"
- rm po/${locale}.po || die
- }
-
- plocale_for_each_disabled_locale cleanup_po
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWZ_DISTRIBUTOR="Gentoo Linux"
- -DWZ_ENABLE_WARNINGS_AS_ERRORS=OFF
- -DWZ_ENABLE_BACKEND_VULKAN=$(usex vulkan)
- -DBUILD_SHARED_LIBS=OFF
- -DENABLE_NLS=$(usex nls)
- -DENABLE_DISCORD=$(usex discord)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- asciidoc -b html5 doc/quickstartguide.asciidoc || die
-}
-
-src_install() {
- cmake_src_install
-
- rm "${ED}"/usr/bin/.portable || die
-
- # We cover licencing within the ebuild itself
- rm "${ED}"/usr/share/doc/${PF}/COPYING* \
- "${ED}"/usr/share/doc/${PF}/copyright || die
-
- if use videos ; then
- insinto /usr/share/${PN}
- newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
- fi
-}