summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-09 08:16:45 +0000
committerSam James <sam@gentoo.org>2023-03-09 08:17:16 +0000
commit95a353dfdae0aa54b145645d48d1fa3cc9b15313 (patch)
tree861eae32bf0e3cf620a94c525d1d4a0268e2484e
parentdev-vcs/git-tools: drop 2019.11 (diff)
downloadgentoo-95a353dfdae0aa54b145645d48d1fa3cc9b15313.tar.gz
gentoo-95a353dfdae0aa54b145645d48d1fa3cc9b15313.tar.bz2
gentoo-95a353dfdae0aa54b145645d48d1fa3cc9b15313.zip
dev-vcs/git-tools: add 2022.12
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-vcs/git-tools/Manifest1
-rw-r--r--dev-vcs/git-tools/git-tools-2022.12.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/git-tools/Manifest b/dev-vcs/git-tools/Manifest
index 86c58a400246..6fb717f241f6 100644
--- a/dev-vcs/git-tools/Manifest
+++ b/dev-vcs/git-tools/Manifest
@@ -1 +1,2 @@
DIST git-tools-2020.09.tar.gz 30365 BLAKE2B 90c6b00b6c88037a90a0987f78ce28e6a9568a05cc750a8a2722fae74e7f7ad63ded5365677446cd19dd9a219c0dce550f8a63c591350cbba7af46837369d981 SHA512 48a6f36aab3e51c2ea3513473b2fe80107d19f131abf89f607492b6fb117419e11c522322beadae5802a1d1388b3430bf48e5dcfec53597453275f62bf13b05b
+DIST git-tools-2022.12.tar.gz 38072 BLAKE2B 3a7c1b4b4082af4ba4e6b6c5e061bf1c10cf58c8f25b7a3acac009fbac67ad10f68819bcd93561b8f76556bb4edf8ed3210300cd4e4733e1a777cf79e5c8532f SHA512 ecd9cef6d4811b701d6770ae04bcd7c6811ed1e0086f96f3108d5d683816ea46b343e1eb653e3a529a5b540168775f458a48f85175292245257b063163904700
diff --git a/dev-vcs/git-tools/git-tools-2022.12.ebuild b/dev-vcs/git-tools/git-tools-2022.12.ebuild
new file mode 100644
index 000000000000..458f0863dd85
--- /dev/null
+++ b/dev-vcs/git-tools/git-tools-2022.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-r1
+
+DESCRIPTION="Assorted git-related scripts"
+HOMEPAGE="https://github.com/MestreLion/git-tools"
+SRC_URI="https://github.com/MestreLion/git-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ ${DEPEND}
+ >=app-shells/bash-4.0
+ >=dev-vcs/git-2.5
+"
+
+src_install() {
+ dobin git-branches-rename git-clone-subset git-find-uncommitted-repos
+ dobin git-rebase-theirs git-strip-merge
+ python_foreach_impl python_doscript git-restore-mtime
+ doman man1/*.1
+ einstalldocs
+}