summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-14 06:54:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-14 07:33:48 +0200
commit95ab006f76029f15e46f9ddbc284c07f7ee6f89d (patch)
treed7eb036dc1809b24d01fafede60787d205ccb2e6
parentdev-python/pymongo: Bump to 4.4.1 (diff)
downloadgentoo-95ab006f76029f15e46f9ddbc284c07f7ee6f89d.tar.gz
gentoo-95ab006f76029f15e46f9ddbc284c07f7ee6f89d.tar.bz2
gentoo-95ab006f76029f15e46f9ddbc284c07f7ee6f89d.zip
dev-python/starlette: Bump to 0.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.30.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 3c40a286ffb1..a70131ac4c7a 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1 +1,2 @@
DIST starlette-0.28.0.gh.tar.gz 2843094 BLAKE2B a3cb35cf465b4540457cffafe4a3bb32081f542b8a5c730bc7fcc0bbf9f7a6c2c21bcc4297c8f3c5281f6ca787aa03c3ee4f90032155d1aa1887440dc289e5c1 SHA512 344c0581e6d6e64abd51347757cba4eb9bfba6f66bf62a2a5491cd3bb1c332895d6827bc478c00d9dfe3043152e814b6870894577a4e9547ac116c66f75a49b1
+DIST starlette-0.30.0.gh.tar.gz 2844387 BLAKE2B 00457d4913bd1c99fc6972baae56c5ebe84ba8215c6dd4f7875f6d93856ba40454d8a72828e715624bb945dce4abfbe407ed16e289a393af7be980f36389f9ae SHA512 751077fcfe3d344584d8986f3fc2bc25208716ca215db8ce62dfc752008dacd95f4834367f0921ceacaafa6b20409a9912f49ceabc23d7e9e5f636c6fb3646b2
diff --git a/dev-python/starlette/starlette-0.30.0.ebuild b/dev-python/starlette/starlette-0.30.0.ebuild
new file mode 100644
index 000000000000..11703340a66f
--- /dev/null
+++ b/dev-python/starlette/starlette-0.30.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest