summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-15 02:40:20 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-15 02:47:43 +0200
commit95afca0166387f882b4115285e777beef847022b (patch)
tree08a54dac8d49eff26069e06a62d9b0803a5d17a9
parentdev-python/imagesize: update DESCRIPTION and upstream metadata (diff)
downloadgentoo-95afca01.tar.gz
gentoo-95afca01.tar.bz2
gentoo-95afca01.zip
dev-python/imagesize: bump to 1.0.0, add tests, fix deps+SRC_URI
Package-Manager: Portage-2.3.42, Repoman-2.3.9
-rw-r--r--dev-python/imagesize/Manifest1
-rw-r--r--dev-python/imagesize/imagesize-1.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/imagesize/Manifest b/dev-python/imagesize/Manifest
index 58530fb31ba6..fe9e04677cdc 100644
--- a/dev-python/imagesize/Manifest
+++ b/dev-python/imagesize/Manifest
@@ -1 +1,2 @@
DIST imagesize-0.7.1.tar.gz 2871 BLAKE2B c458527576b9e55d7bb501667b1283a6362b408339c385c6dc1201538668d0c4708973c8b94faea7151195304eac78071770fc068a65f0b9565f50ea7808395e SHA512 61ff92167cc90bb1dcc78bb358419a526f09dc567709548bbe399694aa15dab63744f56c67bf33a940f5f443fd3a5ddc08ef9e17799b6fede1b11c0ad6a17f75
+DIST imagesize-1.0.0.tar.gz 465373 BLAKE2B aadb78abb6cdba8083c123313e4e35bc2d83cff4034357c6806c9231e6e0be570c871a5ed2e975337a91741aea6ac7643c4cfe3a19e12c184cab0b2f3f51fdd4 SHA512 1111d284cfdb8b14bc09dd0dd569434c62225f0b8da5ca5c00a740fce095c382efafcba73a4000e38b91418775518707693675c2d3c2dafb1036fc4aadb91e64
diff --git a/dev-python/imagesize/imagesize-1.0.0.ebuild b/dev-python/imagesize/imagesize-1.0.0.ebuild
new file mode 100644
index 000000000000..54738deb2736
--- /dev/null
+++ b/dev-python/imagesize/imagesize-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python module for getting image size from png/jpeg/jpeg2000/gif files"
+HOMEPAGE="https://github.com/shibukawa/imagesize_py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x64-solaris"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}