summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-12-10 11:18:51 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-12-10 11:19:20 -0800
commit95d4d7beeaee4503f2af68f938f446d1b3805cb0 (patch)
tree468bdb6e1d13ae03a447051ae9bf50ef38c091d9
parentapp-doc/doxygen: add LLVM 10/11 compatibility patch (diff)
downloadgentoo-95d4d7beeaee4503f2af68f938f446d1b3805cb0.tar.gz
gentoo-95d4d7beeaee4503f2af68f938f446d1b3805cb0.tar.bz2
gentoo-95d4d7beeaee4503f2af68f938f446d1b3805cb0.zip
sys-apps/systemd-tmpfiles: fix postinst for EROOT installations.
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
index 6bcf3413b4e8..0520665a08fd 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
@@ -199,7 +199,7 @@ add_service() {
elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
mkdir -p "${EROOT}/etc/runlevels/${runlevel}"
- ln -snf "${EROOT}/etc/init.d/${initd}" "${EROOT}/etc/runlevels/${runlevel}/${initd}"
+ ln -snf "${EPREFIX}/etc/init.d/${initd}" "${EROOT}/etc/runlevels/${runlevel}/${initd}"
}
pkg_postinst() {