summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-11-13 12:32:41 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-11-13 12:45:00 -0800
commit95ee4b091e3c6e5e1db342a57b6fdee53b095e8c (patch)
tree5d57f7697fea146c6a1b3226d3d0f05f7816b288
parentapp-backup/amanda: fix chown during USE=minimal (diff)
downloadgentoo-95ee4b09.tar.gz
gentoo-95ee4b09.tar.bz2
gentoo-95ee4b09.zip
app-backup/amanda: fix ownership of /etc/amanda/amanda-security.conf
Fixes: https://bugs.gentoo.org/637332 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--app-backup/amanda/amanda-3.5-r1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-backup/amanda/amanda-3.5-r1.ebuild b/app-backup/amanda/amanda-3.5-r1.ebuild
index 673a7b70daee..bbc32ece405d 100644
--- a/app-backup/amanda/amanda-3.5-r1.ebuild
+++ b/app-backup/amanda/amanda-3.5-r1.ebuild
@@ -481,4 +481,13 @@ amanda_permissions_fix() {
chown root:${AMANDA_GROUP_NAME} "${root}"/${i} || die
chmod u=srwx,g=rx,o= "${root}"/${i} || die
done
+
+ # amanda-security.conf is a config file with similar requirements:
+ # writable only by root
+ # world-readable
+ # 3.3.9: introduced in /etc/amanda-security.conf
+ # 3.4.2: moved to /etc/amanda/amanda-security.conf
+ f=/etc/amanda/amanda-security.conf
+ chown root:root "${root}""${f}" || die
+ chmod u=rw,go=r "${root}""${f}" || die
}