summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-14 19:17:27 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-14 19:19:27 +0200
commit95f0e30d05dacb848a0963d0f862447afd5d73cc (patch)
tree5e33c8ef162cb6b0373edb001791053b06ddcfe5
parentgames-puzzle/swell-foop: add missing vala build depend (diff)
downloadgentoo-95f0e30d05dacb848a0963d0f862447afd5d73cc.tar.gz
gentoo-95f0e30d05dacb848a0963d0f862447afd5d73cc.tar.bz2
gentoo-95f0e30d05dacb848a0963d0f862447afd5d73cc.zip
dev-cpp/glibmm: bump to 2.28.0, identical to 2.56.1
Gets it out of the way from bump reports Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.58.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index 72791e8e4f4f..f5e0c74fbc7a 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,2 +1,3 @@
DIST glibmm-2.56.0.tar.xz 6859520 BLAKE2B 8d7f0120de211002d587e6ec0d3750dcdce60abae6506395b318be876d5ed680b1451920063f06d6d9655137d50482a9ba936caa0f6da127bb3855e43b4d877f SHA512 65e577009019e30e340ae5fe6e4c854e5a75551b2eb83ad85403d73eb4e77879783162d4c3c354bc37be0be842f0ddffc1977021a5e0c32985fb596d86929c08
DIST glibmm-2.56.1.tar.xz 6841240 BLAKE2B db0e1402f322fd31138cf4db2fc2fabb6fb9896f226f98bd524fe005f0e3412f6973774571b7ec79a9e3c79f6622b0969a55dc91631cc996906dd1e558ad4fe8 SHA512 fd5ad19c5dcba484573520e1d00b5bbb600ee805ab8cd9c0d985880cc1bcbe67ad31fa9f2b5789b5892eddd6be345e3f308593e5ef021e1cfda132e4235fb735
+DIST glibmm-2.58.0.tar.xz 6839236 BLAKE2B 62e350e4ad180e2e31c1ec0caad18fb7d3bd46b2a0c52ccb93bfbf7b1260b6b595a690b49e344991ceb4dc75ed818f543424a9fd6df6d91ab3ede31959a7723f SHA512 e376462cdf1a60ed7d7750115200162016f57797674bbf7291c11b8754a6e4394eb1e2948ce4e37247438120dba4e18f5cf9c543963c1e97d8561d174d5ae7df
diff --git a/dev-cpp/glibmm/glibmm-2.58.0.ebuild b/dev-cpp/glibmm/glibmm-2.58.0.ebuild
new file mode 100644
index 000000000000..cedbe733f1d4
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.58.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.55.1:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ # don't build examples - we want to install example sources, not binaries
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
+ dodoc -r examples
+}