summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-08-11 07:30:32 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-08-11 07:49:51 -0400
commit95f19838fef64c346e780e46937f0ae0eed5a6a2 (patch)
treeeeb6344fab5a279eac2031cc90604d46b0ff1fd0
parentgui-libs/egl-wayland: tidy older versions (diff)
downloadgentoo-95f19838fef64c346e780e46937f0ae0eed5a6a2.tar.gz
gentoo-95f19838fef64c346e780e46937f0ae0eed5a6a2.tar.bz2
gentoo-95f19838fef64c346e780e46937f0ae0eed5a6a2.zip
sci-mathematics/nauty: add 2.7.4
This version also modifies the nauty.pc file to report the same version information that the ebuild contains. This is one of a few bad choices we're bequeathed from the crazy upstream versioning scheme; it probably does no harm and makes the QA warning go away. Closes: https://bugs.gentoo.org/863053 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/nauty/Manifest2
-rw-r--r--sci-mathematics/nauty/nauty-2.7.4.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/Manifest b/sci-mathematics/nauty/Manifest
index be853df66729..67e1508661cb 100644
--- a/sci-mathematics/nauty/Manifest
+++ b/sci-mathematics/nauty/Manifest
@@ -1,3 +1,5 @@
DIST nauty-includes.patch 2530 BLAKE2B 8789bc2f65b89aa3bbf27e517f1c56340f9bde089ef54aa28757c66c3954b5c54e8a09b6989ad8d57098970240dd1838baa0003766fe10c7f6c32041abf461e3 SHA512 d11f530fecb86edc9e95f0b4d91240778047c0e84d6259c80490358baf0a3eeaa112acfe1fcdb594da6c6e17855f5e21cb75c88446b8d6d9e96402be0e5e6af2
DIST nauty27r3.tar.gz 1721200 BLAKE2B 2071f241dc531a056c678be0ec40497421440f2d5f1796ba20c1257feff426a452df592912faadca08010b29afbbc8cc0552c0517c168af3de9f3334b60d7f18 SHA512 8d6d92de8d348d3874677a55773088f4ff5b9a45fd9ed3802c9b1590072f5861946ac1d21892f4b383a9e36f6c9ac08270d021429cf36da3e5038e6a38d9fb6c
+DIST nauty27r4.tar.gz 1731562 BLAKE2B 104481e5af3333b60574a7185848832ad08b0cfeb8378e3c89ddd3f2cc87023cd701889356fa196b529ddbf19232a733fe3e694d9573adef04c2ad86baaf38e5 SHA512 2ed691bf0a6806f77cccbd95ee7687a66b6e6342493a0d65636166727cf4ea8cd887187d88a3154d911f665deb8d6f5bbaba33c8a1b740a564a1fc52bf4b4520
DIST nauty_2.7r3+ds-1.debian.tar.xz 45520 BLAKE2B 5078ab84d1fcdbddc0f7442ebed57fb63551701295615b99f2833c300168dd7f71205fa3cc2e9ea977f52e389b67883b68e7d5d39e1698c6040913e4571fa4f9 SHA512 8618c78a7c6f1d579cb20048fcf55fb45b69d8d1cebd7f2c9aee664768ab78f0ab1930863c8475a153c9ac9f4692cf6e43f96d01c4a219eae1f23bb61cb50407
+DIST nauty_2.7r4+ds-1.debian.tar.xz 45712 BLAKE2B e4a7a1d2b70b5fa969f708bbd56b47aaf422c268be23ffa7ceb3f9cc21ff8d27270556adadd43fe60309e7840e1541a586b1d9d42d90ba6207801e170b747922 SHA512 7384e7637a875c35f6da94707576aa26a94f981a750eb80991a837fa9ae245680f11ca57cf24a9efe1164dcd386c9888270688c1b3de30d1a81b67bb7c670dd9
diff --git a/sci-mathematics/nauty/nauty-2.7.4.ebuild b/sci-mathematics/nauty/nauty-2.7.4.ebuild
new file mode 100644
index 000000000000..d6f312ce894b
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.7.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PV1=$(ver_rs 2 'r')
+MY_PV=$(ver_rs 1 '' $(ver_rs 2 'r'))
+DEBIAN_PATCH_VERSION=1
+
+DESCRIPTION="Computing automorphism groups of graphs and digraphs"
+HOMEPAGE="https://pallini.di.uniroma1.it/"
+
+SRC_URI="https://pallini.di.uniroma1.it/${PN}${MY_PV}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV1}+ds-${DEBIAN_PATCH_VERSION}.debian.tar.xz
+ https://src.fedoraproject.org/rpms/nauty/raw/f35/f/nauty-includes.patch"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="examples"
+
+BDEPEND="sys-apps/help2man"
+DEPEND="dev-libs/gmp:0
+ sys-libs/zlib
+ sci-mathematics/cliquer"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+DOCS=( schreier.txt formats.txt changes24-27.txt )
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches/upstream-fix-gt_numorbits.patch
+ "${WORKDIR}"/debian/patches/upstream-C2help2man.patch
+ "${WORKDIR}"/debian/patches/upstream-autotoolization.patch
+ "${DISTDIR}"/nauty-includes.patch
+ "${WORKDIR}"/debian/patches/unbundle-cliquer.patch
+)
+
+src_prepare() {
+ default
+ rm makefile || die
+
+ # The debian patch looks for <cliquer.h>, but the autotools-form of
+ # cliquer installs that header as <cliquer/cliquer.h>.
+ sed -e 's~<cliquer\.h>~<cliquer/cliquer\.h>~' -i nautycliquer.h || die
+
+ # The debian autotools patch has only a placeholder in LT_INIT for
+ # the version that we must provide.
+ sed -e "s/@INJECTVER@/${PV}/" -i configure.ac || die
+
+ # This is not great, since consumers should expect to see the
+ # upstream versioning scheme in e.g. PKG_CHECK_MODULES. However, the
+ # upstream version is next to impossible to use for comparisons, so
+ # at least this fixes the QA warning and makes the pkg-config
+ # version useful on Gentoo?
+ sed -e "s/^Version:.*/Version: ${PV}/" -i nauty.pc.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Fedora has a patch to enable popcnt at runtime on CPUs that support it,
+ # but their patch isn't applying cleanly. What's worse, the patch doesn't
+ # support clang (bug 732020).
+ econf --disable-static \
+ --disable-popcnt \
+ --enable-tls \
+ --enable-generic
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc nautyex*.c
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}