summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 03:45:53 +0100
committerSam James <sam@gentoo.org>2022-09-09 03:45:53 +0100
commit95f22c77f1e0f816d1f769421736a8e6888c4de8 (patch)
tree056428f07709b57adf8ffcf660d654687b0a7706
parentwww-client/microsoft-edge: amd64 stable (105.0.1343.33) (diff)
downloadgentoo-95f22c77.tar.gz
gentoo-95f22c77.tar.bz2
gentoo-95f22c77.zip
www-client/microsoft-edge: remove old
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-105.0.1343.27.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 2fbe3f521f72..918fe09fe7f6 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1,2 +1 @@
-DIST microsoft-edge-stable_105.0.1343.27-1_amd64.deb 133569784 BLAKE2B ecd343bee7d893af5828d6f2792d14cbb9dde973fa4cd7abe9a34259e3953bc381bdd72231df6a11f1c77e62fec07cd03b6511f404d7aa09acdc7be3ac671558 SHA512 124eea04fe68631fc983f9a03f317771193731b7f41aa270ff2652d6263eb34b6a01d0a7e9db6b8ae6f460b996ee35bea72557b2d18acc2eb1057cd5e0b53160
DIST microsoft-edge-stable_105.0.1343.33-1_amd64.deb 133907676 BLAKE2B 8b0348ebbbf4fb6962e8003dc4a0cbcade96080c420962227428beb6c1117afac619cf6501b165df7b106fe2930f77056dc48481093c99bf33f8a7f4293b0d7c SHA512 e69e59b9cd39932a4171c9e346ccfe139d9ee076f35e6d8c6162ff6f9228375e4dec89b41a5abb2988fe997b6f71da10e4ecbcb71be9267bdf2d435c1299afd5
diff --git a/www-client/microsoft-edge/microsoft-edge-105.0.1343.27.ebuild b/www-client/microsoft-edge/microsoft-edge-105.0.1343.27.ebuild
deleted file mode 100644
index 3db12034b572..000000000000
--- a/www-client/microsoft-edge/microsoft-edge-105.0.1343.27.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 2011-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit chromium-2 desktop pax-utils unpacker xdg
-
-DESCRIPTION="The web browser from Microsoft"
-HOMEPAGE="https://www.microsoft.com/en-us/edge"
-
-if [[ ${PN} == microsoft-edge ]]; then
- MY_PN=${PN}-stable
-else
- MY_PN=${PN}
-fi
-
-KEYWORDS="-* amd64"
-
-MY_P="${MY_PN}_${PV}-1"
-
-SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
-
-LICENSE="microsoft-edge"
-SLOT="0"
-RESTRICT="bindist mirror strip"
-IUSE="+mip"
-
-RDEPEND="
- app-accessibility/at-spi2-atk:2
- app-accessibility/at-spi2-core:2
- app-misc/ca-certificates
- dev-libs/atk
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- media-fonts/liberation-fonts
- media-libs/alsa-lib
- media-libs/mesa[gbm(+)]
- net-misc/curl[ssl]
- net-print/cups
- sys-apps/dbus
- sys-apps/util-linux
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3[X]
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libxcb
- x11-libs/libxkbcommon
- x11-libs/libxshmfence
- x11-libs/pango
- x11-misc/xdg-utils
- mip? ( app-crypt/libsecret )
-"
-
-QA_PREBUILT="*"
-QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
-S=${WORKDIR}
-EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
-}
-
-pkg_pretend() {
- # Protect against people using autounmask overzealously
- use amd64 || die "microsoft-edge only works on amd64"
-}
-
-pkg_setup() {
- chromium_suid_sandbox_check_kernel_config
-}
-
-src_unpack() {
- :
-}
-
-src_install() {
- dodir /
- cd "${ED}" || die
- unpacker
-
- rm _gpgorigin || die
-
- rm -r etc usr/share/menu || die
- mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
-
- gzip -d usr/share/doc/${PF}/changelog.gz || die
- gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
- if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
- rm usr/share/man/man1/${PN}.1.gz || die
- dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
- fi
-
- local suffix=
- [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
- [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
-
- local size
- for size in 16 24 32 48 64 128 256 ; do
- newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
- done
-
- if ! use mip; then
- rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
- fi
-
- pax-mark m "${EDGE_HOME}/msedge"
-}