summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-11 14:40:06 -0400
committerSam James <sam@gentoo.org>2024-04-11 22:33:19 +0100
commit95f26136eef6b81d752e4ddf102934306f69c581 (patch)
tree87357ffe479825cc19422bbdab0218d3e187e3f2
parentdev-tex/dot2tex: PEP 517 + Python 3.12 (diff)
downloadgentoo-95f26136eef6b81d752e4ddf102934306f69c581.tar.gz
gentoo-95f26136eef6b81d752e4ddf102934306f69c581.tar.bz2
gentoo-95f26136eef6b81d752e4ddf102934306f69c581.zip
dev-games/aseprite: mark as LTO-unsafe, strict-aliasing unsafe
It has all the issues, and then throws in another issue with a bundled skia too just for kicks. Closes: https://bugs.gentoo.org/924692 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-games/aseprite/aseprite-1.2.40.ebuild15
-rw-r--r--dev-games/aseprite/aseprite-1.3.2.ebuild15
2 files changed, 28 insertions, 2 deletions
diff --git a/dev-games/aseprite/aseprite-1.2.40.ebuild b/dev-games/aseprite/aseprite-1.2.40.ebuild
index db187de2e8df..2a603fddfb1f 100644
--- a/dev-games/aseprite/aseprite-1.2.40.ebuild
+++ b/dev-games/aseprite/aseprite-1.2.40.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake desktop ninja-utils python-any-r1 toolchain-funcs xdg-utils
+inherit cmake desktop flag-o-matic ninja-utils python-any-r1 toolchain-funcs xdg-utils
SKIA_VER="m102"
# Last commit in ${SKIA_VER} feature branch
@@ -96,6 +96,19 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing, -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924692
+ # https://github.com/aseprite/aseprite/issues/4413
+ #
+ # There is a bundled skia that fails with ODR errors. When excluding just
+ # skia from testing, aseprite itself fails with strict-aliasing, and when
+ # that is disabled, fails again with ODR and lto-type-mismatch issues.
+ #
+ # There are a lot of issues, so don't trust any fixes without thorough
+ # testing.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
einfo "Skia configuration"
cd "${WORKDIR}/skia-${SKIA_REV}" || die
diff --git a/dev-games/aseprite/aseprite-1.3.2.ebuild b/dev-games/aseprite/aseprite-1.3.2.ebuild
index a5dfeae7a147..7630df8d90a4 100644
--- a/dev-games/aseprite/aseprite-1.3.2.ebuild
+++ b/dev-games/aseprite/aseprite-1.3.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake desktop python-any-r1 toolchain-funcs xdg-utils
+inherit cmake desktop flag-o-matic python-any-r1 toolchain-funcs xdg-utils
SKIA_VER="m102"
# Last commit in ${SKIA_VER} feature branch
@@ -96,6 +96,19 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing, -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924692
+ # https://github.com/aseprite/aseprite/issues/4413
+ #
+ # There is a bundled skia that fails with ODR errors. When excluding just
+ # skia from testing, aseprite itself fails with strict-aliasing, and when
+ # that is disabled, fails again with ODR and lto-type-mismatch issues.
+ #
+ # There are a lot of issues, so don't trust any fixes without thorough
+ # testing.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
einfo "Skia configuration"
cd "${WORKDIR}/skia-${SKIA_REV}" || die