summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-10-30 17:17:28 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-10-30 18:36:42 -0700
commit960f8f490125d1955fc5637435bab69895d64ffc (patch)
tree87f2370fc79a6218925222131e4d7e4b97bddc6c
parentdev-python/pytest-tempdir-2019.10.12: add py39 (diff)
downloadgentoo-960f8f49.tar.gz
gentoo-960f8f49.tar.bz2
gentoo-960f8f49.zip
dev-python/pytest-salt-factories-0.94.4: bump, add py39
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pytest-salt-factories/Manifest1
-rw-r--r--dev-python/pytest-salt-factories/pytest-salt-factories-0.94.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-salt-factories/Manifest b/dev-python/pytest-salt-factories/Manifest
index af8b1dec4dd4..ebba53b1328e 100644
--- a/dev-python/pytest-salt-factories/Manifest
+++ b/dev-python/pytest-salt-factories/Manifest
@@ -1 +1,2 @@
DIST pytest-salt-factories-0.92.0.tar.gz 112049 BLAKE2B 054ec70df87bb1c1ccd4217ddf66b1efa1329d95c72cc40a633b5516afbe5bc80b4210560438e039def40a5c4aec3730a36f83c7911fd3a12a7bd5d33d388986 SHA512 308a446c870528437967eb5b3167861818311683dd9c4f55af8aa1766cde29ab438e5bf0ba922933d893f1a5469af4b827c422e59adb12cb2b422302550dfdd5
+DIST pytest-salt-factories-0.94.4.tar.gz 117281 BLAKE2B 9b42dbf4329fe2afd875de55e96604896c6f46d3c3736b644466dd5db6091cf5b9b1d2188c0e0a22b4b15a227dfacc7692ea6499aa7f58ce6adb9b802f00b1f7 SHA512 5c670aa7dd64441b1bd3a188335a35be00d7406bc8d76f9a1213cc3414061c3dfc51a9319008c29c83fb5abec1d7b677aec76ac4b9c00adcd878ef6da599041a
diff --git a/dev-python/pytest-salt-factories/pytest-salt-factories-0.94.4.ebuild b/dev-python/pytest-salt-factories/pytest-salt-factories-0.94.4.ebuild
new file mode 100644
index 000000000000..4568ef158e69
--- /dev/null
+++ b/dev-python/pytest-salt-factories/pytest-salt-factories-0.94.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="The new generation of the pytest-salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt-factories"
+SRC_URI="https://github.com/saltstack/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-6.1.1[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? ( >=app-admin/salt-3000.0[${PYTHON_USEDEP}] )
+"
+
+# pytest just bombs
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/pytest-salt-factories-0.92.0-setup.patch"
+)
+
+distutils_enable_tests pytest