summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-07 01:06:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-11-07 03:37:54 -0500
commit962c606ee97f5af92821e5acf6af7f0701ac5095 (patch)
tree01812fbd6abe2109f70399c9c67acf36447d10f1
parentdev-lang/erlang: Bump (diff)
downloadgentoo-962c606e.tar.gz
gentoo-962c606e.tar.bz2
gentoo-962c606e.zip
dev-python/pytest-bdd: re-enable terminal test using COLUMNS
Hadn't thought about it before. Thanks-to: Michał Górny <mgorny@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
index f0ca5bb62830..c3be9a1f2c6a 100644
--- a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
@@ -26,7 +26,9 @@ distutils_enable_tests --install pytest
DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-EPYTEST_DESELECT=(
- # result varies depending on current output terminal width
- tests/feature/test_gherkin_terminal_reporter.py::test_verbose_mode_should_preserve_displaying_regular_tests_as_usual
-)
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ distutils-r1_src_test
+}