summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 22:10:55 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 22:26:38 -0600
commit963e7cd1706476cfcdb85cccd54475d9fa6ffccc (patch)
treecf7865ee24764c058a68e5024ec388eb40cd17bd
parentdev-python/oslo-vmware: bup (diff)
downloadgentoo-963e7cd1.tar.gz
gentoo-963e7cd1.tar.bz2
gentoo-963e7cd1.zip
dev-python/os-win: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/os-win/Manifest1
-rw-r--r--dev-python/os-win/os-win-1.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/os-win/Manifest b/dev-python/os-win/Manifest
index cfbc32b088b7..db09dd7a962d 100644
--- a/dev-python/os-win/Manifest
+++ b/dev-python/os-win/Manifest
@@ -1,2 +1,3 @@
DIST os-win-0.4.0.tar.gz 134421 SHA256 369d9483340ab48a5c145e4863082d2c611a02a467b7609227e3432a26880283 SHA512 6ffc33c8dbeb834ee588a8b84fb3fc6d7f6bf886d22307cac46c6f769c0d645bc76fd432be0cd8d3b76d0119ef6f5fe3276482cfda7880462f7af6969748a53e WHIRLPOOL 6c3c643b3992f98eb8551d19d067e8a56809a10005abf0940c270a77c4f1066469b367045c6e1be9f453b87db67f4f7fe9d3f614589887bc0e5d1d46c62b2099
DIST os-win-1.2.1.tar.gz 157535 SHA256 be9749c8bd49d9a65895b8324374e3beafd6e3b0987840e87a888f03e194a7a7 SHA512 2893dda81267fa451afe3e0570b30fc835587237ec20ebc67d0fb454bcf2d0bcf8cfe215e6103f2a165f68c9ccabefd7ff0dbd08b2d52da49f96b2b8fc84cb50 WHIRLPOOL 7189aa28f04cce6d5119030be2fbd875c77d2e2af4f5b93244fbda4817d3090bb78d4d58dbf90b2e26af1ea72220faa14fbe2f8db025e83305d758c34df932cf
+DIST os-win-1.4.0.tar.gz 170216 SHA256 7784009a79de59307ac47db8674dcb27353903eba9da552dda24b4a4ac13e27a SHA512 40ff1eec24ad46824e21e38cb4c2f7d74cef057dc6ca77479a1b6535de0fa6b7ff805e71585bf95b439038217d62ebc8fc4872effe53c4f172f845c2d41872c8 WHIRLPOOL f28014a77b37652b4d4ace402c3a3ab56b330003af980d81e2c70ab0aa4837acb9ea7aa1b922f9ee81b743e68f344bc386c2e979050d8a5e016da2549b7113b9
diff --git a/dev-python/os-win/os-win-1.4.0.ebuild b/dev-python/os-win/os-win-1.4.0.ebuild
new file mode 100644
index 000000000000..d54c25148e65
--- /dev/null
+++ b/dev-python/os-win/os-win-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}