summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-21 03:12:53 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-21 03:23:24 -0400
commit9641aebf3905c80e32c0007b8f45e996fa0276aa (patch)
tree73f7a640c846122e082c2e6b391007dc61cab295
parentdev-util/cargo-c: fix build with >=libgit2-1.8.0 (diff)
downloadgentoo-9641aebf3905c80e32c0007b8f45e996fa0276aa.tar.gz
gentoo-9641aebf3905c80e32c0007b8f45e996fa0276aa.tar.bz2
gentoo-9641aebf3905c80e32c0007b8f45e996fa0276aa.zip
media-video/rav1e: fix build with >=libgit2-1.8.0
libgit2-sys crate has a upper bound for <1.8.0 and refuses to build otherwise, but not seeing(?) any issues with it. Just a quick emergency fix, will likely be fixed next libgit2-sys version. Kept full version in the sed's path rather than a glob to force re-checking this when the crate is bumped. Alternatively could drop LIBGIT2_NO_VENDOR or set an upper bound in RDEPEND, but does not seem necessary. Note 9999 is still broken albeit hopefully the crate will just be fixed upstream in time. 9999 users could keep old libgit2 meanwhile. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-video/rav1e/rav1e-0.7.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/media-video/rav1e/rav1e-0.7.1.ebuild b/media-video/rav1e/rav1e-0.7.1.ebuild
index 306e34120246..23fc76363178 100644
--- a/media-video/rav1e/rav1e-0.7.1.ebuild
+++ b/media-video/rav1e/rav1e-0.7.1.ebuild
@@ -281,6 +281,14 @@ src_unpack() {
fi
}
+src_prepare() {
+ default
+
+ # libgit2-sys unnecessarily(?) requests <libgit2-1.8.0, bump to 2 for now
+ sed -e '/range_version/s/1\.8\.0/2/' \
+ -i "${ECARGO_VENDOR}"/libgit2-sys-0.16.1+1.7.1/build.rs || die
+}
+
src_compile() {
# used by build script to get rav1e repository info
export LIBGIT2_NO_VENDOR=1