summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-05-07 18:01:51 +0300
committerSam James <sam@gentoo.org>2021-05-31 14:11:32 +0000
commit964d7dde6015ceb12521877cab13a918d00cbfed (patch)
tree830041bb1f937cfd86863cdb9e655a8ceacc1a83
parentdev-python/cloudscraper: New package (diff)
downloadgentoo-964d7dde6015ceb12521877cab13a918d00cbfed.tar.gz
gentoo-964d7dde6015ceb12521877cab13a918d00cbfed.tar.bz2
gentoo-964d7dde6015ceb12521877cab13a918d00cbfed.zip
media-gfx/hydrus: New package
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Closes: https://github.com/gentoo/gentoo/pull/20720 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/files/hydrus-client3
-rw-r--r--media-gfx/hydrus/files/hydrus-server2
-rw-r--r--media-gfx/hydrus/files/userpath-in-local-share.patch12
-rw-r--r--media-gfx/hydrus/hydrus-441.ebuild156
-rw-r--r--media-gfx/hydrus/metadata.xml26
6 files changed, 200 insertions, 0 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
new file mode 100644
index 000000000000..0265c837b479
--- /dev/null
+++ b/media-gfx/hydrus/Manifest
@@ -0,0 +1 @@
+DIST hydrus-441.tar.gz 38807432 BLAKE2B e8294a8eb4d808792f2ff50ad4776f078ba1003962b065883ec22fd68f46dc250b2bccf47005731fcc964b75e07977aed45023da1c7e4513fcfcc29d1b4d1a97 SHA512 81eeb59006644b9b33c33c8da3e003640116488509ce2e1426d2a5c0161adf208e31a45c2a5efc2902769bf91e3db56aabc6384f77e8354e0e113bcc6df3a131
diff --git a/media-gfx/hydrus/files/hydrus-client b/media-gfx/hydrus/files/hydrus-client
new file mode 100644
index 000000000000..7a6e42747c5c
--- /dev/null
+++ b/media-gfx/hydrus/files/hydrus-client
@@ -0,0 +1,3 @@
+#!/bin/sh
+export QT_API="${QT_API:-pyside2}"
+exec /usr/bin/python -OO /opt/hydrus/client.pyw "$@"
diff --git a/media-gfx/hydrus/files/hydrus-server b/media-gfx/hydrus/files/hydrus-server
new file mode 100644
index 000000000000..cecb9adc1a2d
--- /dev/null
+++ b/media-gfx/hydrus/files/hydrus-server
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/python -OO /opt/hydrus/server.py "$@"
diff --git a/media-gfx/hydrus/files/userpath-in-local-share.patch b/media-gfx/hydrus/files/userpath-in-local-share.patch
new file mode 100644
index 000000000000..8b4c12be071e
--- /dev/null
+++ b/media-gfx/hydrus/files/userpath-in-local-share.patch
@@ -0,0 +1,12 @@
+diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
+index 05fff23..d68fc06 100644
+--- a/hydrus/core/HydrusConstants.py
++++ b/hydrus/core/HydrusConstants.py
+@@ -67,6 +67,7 @@ if USERPATH_DB_DIR == desired_userpath_db_dir:
+
+ USERPATH_DB_DIR = None
+
++USERPATH_DB_DIR = os.path.expanduser ( os.path.join( '~', '.local', 'share', 'hydrus', 'db' ) )
+
+ LICENSE_PATH = os.path.join( BASE_DIR, 'license.txt' )
+
diff --git a/media-gfx/hydrus/hydrus-441.ebuild b/media-gfx/hydrus/hydrus-441.ebuild
new file mode 100644
index 000000000000..ae3f806847c6
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-441.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 desktop optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="http://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+mpv +ffmpeg +lz4 socks +cloudscraper charts test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/psutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyside2[widgets,gui,charts?,${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ dev-python/service_identity[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ dev-python/twisted[${PYTHON_MULTI_USEDEP}]
+ media-libs/opencv[python,${PYTHON_MULTI_USEDEP}]
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+
+ cloudscraper? ( dev-python/cloudscraper[${PYTHON_MULTI_USEDEP}] )
+ ffmpeg? ( media-video/ffmpeg )
+ lz4? ( dev-python/lz4[${PYTHON_MULTI_USEDEP}] )
+ mpv? (
+ media-video/mpv[libmpv,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpv[${PYTHON_MULTI_USEDEP}]
+ )
+ socks? (
+ || ( dev-python/requests[socks5,${PYTHON_MULTI_USEDEP}]
+ dev-python/PySocks[${PYTHON_MULTI_USEDEP}] )
+ )
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ dev-python/unittest2[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+)
+
+# Delete files only needed for testing
+delete_test_files() {
+ rm test.py || die
+ rm hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ || die
+ rm -r static/testing/ || die
+}
+
+src_prepare() {
+ default
+
+ # If tests will run, leave the files until tests are run.
+ # They will be deleted before installing the package.
+ if ! use test; then
+ delete_test_files
+ fi
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI, not actually needed
+ rm -r static/build_files || die
+ # Duplicate license file, not needed
+ rm license.txt || die
+ # Python requirements files, not needed
+ rm requirements_*.txt || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ export QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local DOC="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${DOC}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
+ HTML_DOCS=("${S}"/help/)
+ einstalldocs
+
+ if use test; then
+ # Delete files only needed for tests now. No need to install them.
+ # If the tests didn't run, the files have been deleted already.
+ delete_test_files
+ fi
+
+ # These files are copied into DOC
+ rm COPYING README.md Readme.txt help_my_client_will_not_boot.txt || die
+ rm -r help/ db/ || die
+ # The program expects to find documentation here, so add a symlink to DOC
+ ln -s "${DOC}/html/help" help || die
+
+ insopts -m0755
+ insinto /opt/hydrus
+ doins -r "${S}"/*
+
+ exeinto /usr/bin
+
+ sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" > "${T}/hydrus-server" || die
+ sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" > "${T}/hydrus-client" || die
+
+ python_doexe "${T}/hydrus-server"
+ python_doexe "${T}/hydrus-client"
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png"\
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "support for automatic port forwarding" "net-libs/miniupnpc"
+}
diff --git a/media-gfx/hydrus/metadata.xml b/media-gfx/hydrus/metadata.xml
new file mode 100644
index 000000000000..0b2b3b928087
--- /dev/null
+++ b/media-gfx/hydrus/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>vaartis@kotobank.ch</email>
+ <name>Ekaterina Vaartis</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The hydrus network client is an application written for those who have large image/swf/webm collections. It browses
+ with tags instead of folders, a little like a booru on your desktop. Advanced users can share tags and files
+ anonymously through custom servers that any user may run
+ </longdescription>
+ <use>
+ <flag name="charts">Support for bandwidth charts</flag>
+ <flag name="cloudscraper">Support working around cloudflare anti-bot page</flag>
+ <flag name="ffmpeg">Show duration and other information on video thumbnails</flag>
+ <flag name="lz4">Enable memory compression in the client</flag>
+ <flag name="mpv">Support playing videos with libmpv</flag>
+ <flag name="socks">Support SOCKS proxies</flag>
+ </use>
+ <stabilize-allarches/>
+</pkgmetadata>