summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 22:34:15 +0100
committerSam James <sam@gentoo.org>2022-07-02 22:49:49 +0100
commit964f6ee39180cdce600d9989f02fc377eb6dab8b (patch)
treed50edebb3d414e618a11b5954874bcb9a05468dc
parentprofiles: last-rite app-pda/{jpilot,pilot-link} (diff)
downloadgentoo-964f6ee39180cdce600d9989f02fc377eb6dab8b.tar.gz
gentoo-964f6ee39180cdce600d9989f02fc377eb6dab8b.tar.bz2
gentoo-964f6ee39180cdce600d9989f02fc377eb6dab8b.zip
app-shells/psh: update EAPI 6->8
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/psh/Manifest2
-rw-r--r--app-shells/psh/psh-1.8.1-r3.ebuild40
-rw-r--r--app-shells/psh/psh-1.8.1-r4.ebuild46
3 files changed, 47 insertions, 41 deletions
diff --git a/app-shells/psh/Manifest b/app-shells/psh/Manifest
index 8abeaf0d0ca7..ea8b44f46f40 100644
--- a/app-shells/psh/Manifest
+++ b/app-shells/psh/Manifest
@@ -1 +1 @@
-DIST psh-1.8.1-r3.tar.gz 120552 BLAKE2B 68ada33507a780e60e478362406c778ea6f0a68228807c1677371052ef1d40be64c730fc0bf0d1cdd4a915739ecbffcfcd3a16de931c28c3e5ec11a3116920ff SHA512 01e9def98fa89f347ad540cbb0584773de4b7e11595432d7b8e1f1a563725004b898a5fd30f39b01de661ac6ec3274b6cfecdbd7f0bec3fe175119493163ca9a
+DIST psh-1.8.1.tar.gz 120552 BLAKE2B 68ada33507a780e60e478362406c778ea6f0a68228807c1677371052ef1d40be64c730fc0bf0d1cdd4a915739ecbffcfcd3a16de931c28c3e5ec11a3116920ff SHA512 01e9def98fa89f347ad540cbb0584773de4b7e11595432d7b8e1f1a563725004b898a5fd30f39b01de661ac6ec3274b6cfecdbd7f0bec3fe175119493163ca9a
diff --git a/app-shells/psh/psh-1.8.1-r3.ebuild b/app-shells/psh/psh-1.8.1-r3.ebuild
deleted file mode 100644
index 00fa615132c7..000000000000
--- a/app-shells/psh/psh-1.8.1-r3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-DIST_EXAMPLES=( "examples/*" )
-
-inherit perl-module
-
-DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
-HOMEPAGE="https://gnp.github.io/psh/"
-SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz -> ${PF}.tar.gz"
-S="${WORKDIR}/${PN}-${P}" # github--
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="readline"
-
-RDEPEND="
- readline? (
- dev-perl/Term-ReadLine-Gnu
- dev-perl/TermReadKey
- )
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-
-myinst="SITEPREFIX=${D}/usr"
-
-PATCHES=(
- "${FILESDIR}/${PF}-defined-array.patch"
- "${FILESDIR}/${PF}-array-ref-deprecated.patch"
-)
-
-src_install() {
- perl-module_src_install
- docompress -x "/usr/share/doc/${PF}/pod"
- docinto pod/
- dodoc -r doc/*
-}
diff --git a/app-shells/psh/psh-1.8.1-r4.ebuild b/app-shells/psh/psh-1.8.1-r4.ebuild
new file mode 100644
index 000000000000..9e7a280fb0c5
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_EXAMPLES=( "examples/*" )
+
+inherit optfeature perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="https://gnp.github.io/psh/"
+SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${P}
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-r3-defined-array.patch
+ "${FILESDIR}"/${P}-r3-array-ref-deprecated.patch
+)
+
+src_install() {
+ myinst="SITEPREFIX=${D}/usr"
+
+ perl-module_src_install
+
+ docompress -x /usr/share/doc/${PF}/pod
+
+ docinto pod/
+ dodoc -r doc/*
+}
+
+pkg_postinst() {
+ optfeature "ulimit functionality" dev-perl/BSD-Resource
+}