summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-25 23:08:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-25 23:08:56 -0500
commit96682bed495f1578bcbd7db974910ff9ffd52b41 (patch)
tree01f4887eb6d0dae309c7107a2ce2d9803431799b
parentsys-apps/portage: version bump to 2.3.65 (diff)
downloadgentoo-96682bed495f1578bcbd7db974910ff9ffd52b41.tar.gz
gentoo-96682bed495f1578bcbd7db974910ff9ffd52b41.tar.bz2
gentoo-96682bed495f1578bcbd7db974910ff9ffd52b41.zip
app-admin/ansible: 2.8.0_rc1 bump for ago
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.8.0_rc1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 2b61ab1a41fa..b8f5da0a5d21 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -4,3 +4,4 @@ DIST ansible-2.6.15.tar.gz 10734433 BLAKE2B 9c48d9de348a11a57b364921af26154b5a21
DIST ansible-2.6.16.tar.gz 10738431 BLAKE2B b801eb524f631950c385f7a949bdeae288e95d1590ea96f98e955f6ebc4ccfc5970e3926727850e7ef13fbcd7118ad6388e516a8fe62b53f1bf8b4d5b484dbab SHA512 ff67803cf6afd512ab779b7c862d4427591c90bb0ed9391e32fc8ea30c24c70cc31c910c9af51b4dd423885f858f65c1c8d6274565c90296ecd7a00df3374977
DIST ansible-2.7.10.tar.gz 11844278 BLAKE2B c847b642ebe4cbc2194538a0b194cd5c0bb82e0ba2a6da2e272670c75596b9793e028d067ddb37000c07f2c2427b5b99248b16c544daed4976c0210b601d3c97 SHA512 4d58ef080c8ee02ef36eb3116ec89e4542b5b4042262953b2001081601fe1066237191cce5e647f354efa9e1933cf5010519d049e678a90e8ca08620cd1788a5
DIST ansible-2.7.9.tar.gz 11830476 BLAKE2B 7688ce9f74b0ab1fafd0e31dce90d995a9d8ca90bbe436f2d4ee9d005069b6e1b2c4dd679c2430a6873233da54ae06d3ebf08736681ec2e59e5b3ddafa6bb1e2 SHA512 4d39c7d4eb97264ce8f92812fb986b24af0c663efa6d8cd1d9a4cb25731d55e7518e503c04764e62d0458916b601baaa7acc623f9f83ce8b93e7f22900e29a53
+DIST ansible-2.8.0rc1.tar.gz 14280595 BLAKE2B 7de03e7c85d20c45724b501e04389c58b8a82db3c0600d41a6b751701c9ba6aaaaca5e135858283a55ad7b2edb4ccfe22377437ff3e58ee3c6c0f28693805f8c SHA512 00e51b5098d1e0b41bf05c200a285cac3ffb80ece72c66440c05af6ed36df104faebbbcc484995753b8a521d3f5f18ae773b0d568cdfe4bd87b2fd8aabb8a512
diff --git a/app-admin/ansible/ansible-2.8.0_rc1.ebuild b/app-admin/ansible/ansible-2.8.0_rc1.ebuild
new file mode 100644
index 000000000000..cf0287d8b273
--- /dev/null
+++ b/app-admin/ansible/ansible-2.8.0_rc1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${PN}-2.8.0rc1.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_prepare_all() {
+ rm -fv MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}