summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-07 09:47:53 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-07 09:48:34 +0200
commit967d0ecf3f118dae84b7d100d3464f26cc3d33f7 (patch)
treeeee2cf63f54ecb99383566e0590d4ff8bb249b6e
parentnet-misc/ntp: Rev bump to fix regression caused by libressl patch (diff)
downloadgentoo-967d0ecf.tar.gz
gentoo-967d0ecf.tar.bz2
gentoo-967d0ecf.zip
dev-libs/STLport: Remove from tree
-rw-r--r--dev-libs/STLport/Manifest2
-rw-r--r--dev-libs/STLport/STLport-5.2.1-r1.ebuild95
-rw-r--r--dev-libs/STLport/STLport-5.2.1-r3.ebuild100
-rw-r--r--dev-libs/STLport/files/STLport-5.2.1-time-facets.patch12
-rw-r--r--dev-libs/STLport/metadata.xml14
-rw-r--r--profiles/package.mask7
6 files changed, 0 insertions, 230 deletions
diff --git a/dev-libs/STLport/Manifest b/dev-libs/STLport/Manifest
deleted file mode 100644
index 24e39d97bcba..000000000000
--- a/dev-libs/STLport/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST STLport-5.2.1.tar.bz2 717202 SHA256 755b007b982c4545086c43affc8ed32c0acd577ee206eb1f6967e250c3546fc9 SHA512 c619f1965e42a444714f6a2bcbade3428e09823ad056930b32bf8224b7b3e4b4ae82e25e4ba7b4584f73645a7838a677f314b7bc583d1d9bbcef6fcafc439141 WHIRLPOOL 0d8539b98dd57c8b548bcfaeed3866c348f7f750b676404f40b2beda3c5095a2d94496d670e9f13b7287033fecd8c9f997aad44dfb07b310a8236956bdf2d52e
-DIST STLport-patches-5.2.1-2.tbz2 5245 SHA256 ccf0803a0b5e3c887e52d6132eb48932d566a933d299ebb22858ebd39dddc0c4 SHA512 ddc1b282d1b8008f1f6d5aa3eee0f821063c00fdf851cb569f69955dd3e1ad46b3e57a5c458a1f54aa75737cafe848cf20685b729951a58e80f14234804b92bb WHIRLPOOL cbb1ba74aca4cd454855aad6371ac7140fef42aa70b30c29e70a3b6d24044e5acd221a5a12c90414fb20bfb26ea879e7e3839ff8857b717d793538ca67380e33
diff --git a/dev-libs/STLport/STLport-5.2.1-r1.ebuild b/dev-libs/STLport/STLport-5.2.1-r1.ebuild
deleted file mode 100644
index a7adff98e468..000000000000
--- a/dev-libs/STLport/STLport-5.2.1-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils versionator toolchain-funcs multilib
-
-PATCH_V="2"
-
-DESCRIPTION="C++ STL library"
-HOMEPAGE="http://stlport.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2
- https://dev.gentoo.org/~xarthisius/distfiles/${PN}-patches-${PV}-${PATCH_V}.tbz2"
-
-LICENSE="boehm-gc HPND"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="boost debug static static-libs threads"
-
-DEPEND="boost? ( >=dev-libs/boost-1.35.0-r5 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- # make sure OSNAME is not in the environment (bug #305399)
- unset OSNAME
-}
-
-src_prepare() {
- EPATCH_SOURCE="${WORKDIR}/patches"
- EPATCH_SUFFIX="diff"
- epatch
-
- # We have to add this to host.h to make sure
- # that dependencies of STLport use the same settings
- cat <<- EOF >> stlport/stl/config/host.h
- #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
- /* use pthreads for threading */
- #define _PTHREADS
- /* enable largefile support */
- #define _FILE_OFFSET_BITS 64
- #define _LARGEFILE_SOURCE
- #define _LARGEFILE64_SOURCE
- EOF
-}
-
-src_configure() {
- local myconf
-
- if use boost ; then
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
-
- myconf+="--with-boost=${BOOST_INC} --with-system-boost "
- # make sure user apps (e.g. other packges using STLport) use boost as well
- sed -i \
- -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
- stlport/stl/config/user_config.h
- fi
-
- use debug || myconf+="--without-debug "
- use static-libs && myconf+="--enable-static "
- use threads || myconf+="--without-thread "
- use static && myconf+="--use-static-gcc "
-
- # It's not an autoconf script
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --use-compiler-family=gcc \
- ${myconf} \
- --with-cc="$(tc-getCC)" \
- --with-cxx="$(tc-getCXX)" \
- --with-extra-cflags="${CFLAGS}" \
- --with-extra-cxxflags="${CXXFLAGS}" \
- --with-extra-ldflags="${LDFLAGS}" || die "configure failed"
-}
-
-src_install() {
- # precreate some directories
- dodir /usr/$(get_libdir)
-
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc README etc/ChangeLog etc/*.txt doc/*.txt doc/{FAQ,README.utf8}
-}
-
-src_test() {
- if use static ; then
- ewarn "Tests don't work when building with USE=static. Skipping..."
- return
- fi
- default
-}
diff --git a/dev-libs/STLport/STLport-5.2.1-r3.ebuild b/dev-libs/STLport/STLport-5.2.1-r3.ebuild
deleted file mode 100644
index b1733467a88a..000000000000
--- a/dev-libs/STLport/STLport-5.2.1-r3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils versionator toolchain-funcs multilib
-
-PATCH_V="2"
-
-DESCRIPTION="C++ STL library"
-HOMEPAGE="http://stlport.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2
- https://dev.gentoo.org/~xarthisius/distfiles/${PN}-patches-${PV}-${PATCH_V}.tbz2"
-
-LICENSE="boehm-gc HPND"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="boost debug static static-libs threads"
-
-DEPEND="boost? ( dev-libs/boost:= )"
-RDEPEND="${DEPEND}"
-
-DOCS=( README etc/ChangeLog doc/FAQ doc/README.utf8 )
-
-pkg_setup() {
- # make sure OSNAME is not in the environment (bug #305399)
- unset OSNAME
-}
-
-src_prepare() {
- EPATCH_SOURCE="${WORKDIR}/patches"
- EPATCH_SUFFIX="diff"
- epatch
-
- # We have to add this to host.h to make sure
- # that dependencies of STLport use the same settings
- cat <<- EOF >> stlport/stl/config/host.h
- #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
- /* use pthreads for threading */
- #define _PTHREADS
- /* enable largefile support */
- #define _FILE_OFFSET_BITS 64
- #define _LARGEFILE_SOURCE
- #define _LARGEFILE64_SOURCE
- EOF
-
- # bug #562926
- epatch "${FILESDIR}/${P}-time-facets.patch"
-
- epatch_user
-}
-
-src_configure() {
- local myconf
-
- if use boost ; then
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
-
- myconf+="--with-boost=${BOOST_INC} --with-system-boost "
- # make sure user apps (e.g. other packges using STLport) use boost as well
- sed -i \
- -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
- stlport/stl/config/user_config.h || die
- fi
-
- # It's not an autoconf script
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --use-compiler-family=gcc \
- $(use debug || echo "--without-debug") \
- $(use static && echo "--use-static-gcc") \
- $(use static-libs && echo "--enable-static") \
- $(use threads && echo "--without-thread") \
- ${myconf} \
- --with-cc="$(tc-getCC)" \
- --with-cxx="$(tc-getCXX)" \
- --with-extra-cflags="${CFLAGS}" \
- --with-extra-cxxflags="${CXXFLAGS}" \
- --with-extra-ldflags="${LDFLAGS}" || die "configure failed"
-}
-
-src_install() {
- # precreate some directories
- dodir /usr/$(get_libdir)
-
- default
- dodoc etc/*.txt doc/*.txt
-}
-
-src_test() {
- if use static ; then
- ewarn "Tests don't work when building with USE=static. Skipping..."
- else
- default
- fi
-}
diff --git a/dev-libs/STLport/files/STLport-5.2.1-time-facets.patch b/dev-libs/STLport/files/STLport-5.2.1-time-facets.patch
deleted file mode 100644
index 85a5a325bd5c..000000000000
--- a/dev-libs/STLport/files/STLport-5.2.1-time-facets.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -uNptr a/src/time_facets.cpp b/src/time_facets.cpp
---- a/src/time_facets.cpp 2008-12-10 10:56:51.000000000 +0100
-+++ b/src/time_facets.cpp 2015-10-11 12:07:55.841141984 +0100
-@@ -428,7 +428,7 @@ void _STLP_CALL __write_formatted_timeT(
- break;
- {
- int diff;
--# if defined (__USE_BSD) || defined (__BEOS__)
-+# if defined (__USE_MISC) || defined (__USE_BSD) || defined (__BEOS__)
- diff = t->tm_gmtoff;
- # else
- diff = t->__tm_gmtoff;
diff --git a/dev-libs/STLport/metadata.xml b/dev-libs/STLport/metadata.xml
deleted file mode 100644
index c6229886288c..000000000000
--- a/dev-libs/STLport/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cpp@gentoo.org</email>
- <name>Gentoo C++ Project</name>
- </maintainer>
- <use>
- <flag name="boost">Enable the usage of <pkg>dev-libs/boost</pkg></flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">stlport</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index e6598178ae87..6da35bdbe574 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -231,13 +231,6 @@ app-emulation/wine-any
# Part of the JDK since Java 6. Removal in 30 days.
dev-java/jaxme
-# David Seifert <soap@gentoo.org> (05 Apr 2017)
-# Abandoned, no releases since 2008, only partially
-# compatible with C++11, multiple bugs, upstream dead
-# Masked for removal in 30 days.
-# Bugs #359247, #400547, #409119, #594144
-dev-libs/STLport
-
# Mike Gilbert <floppym@gentoo> (05 Apr 2017)
# Unmaintained.
# Pinned dependencies cause conflicts with other packages.