summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-03 22:55:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-03 22:55:41 +0200
commit96866b391464cf42acd1348e85be6209754641c2 (patch)
tree718f446a088ce2b1d544f1da6f2941277e6c0eca
parentdev-python/setuptools: Switch back to pypi sdist to fix bootstrap (diff)
downloadgentoo-96866b39.tar.gz
gentoo-96866b39.tar.bz2
gentoo-96866b39.zip
dev-ml/ppx_tools: 6.5 bump
Closes: https://bugs.gentoo.org/836369 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/ppx_tools/Manifest1
-rw-r--r--dev-ml/ppx_tools/ppx_tools-6.3.ebuild7
-rw-r--r--dev-ml/ppx_tools/ppx_tools-6.4.ebuild7
-rw-r--r--dev-ml/ppx_tools/ppx_tools-6.5.ebuild21
4 files changed, 32 insertions, 4 deletions
diff --git a/dev-ml/ppx_tools/Manifest b/dev-ml/ppx_tools/Manifest
index be9333053897..f2ed5e6ef0a7 100644
--- a/dev-ml/ppx_tools/Manifest
+++ b/dev-ml/ppx_tools/Manifest
@@ -1,3 +1,4 @@
DIST ppx_tools-6.2.tar.gz 46150 BLAKE2B f8af2a1eee81d5a1e73ac606ab79d285c8c226533bcf715ed22386aecfaf51260fb9a5075d270675f1b601cb174b68d8c85556f418031a7b6bda06c4376fe443 SHA512 fc3943c69901ef46843355c3482d5a1481d05ee94fb0a344ec04101059a02cbaa76fed5742cfae82730edf378f2e140d859a5cf590653f85359255d451f07dc8
DIST ppx_tools-6.3.tar.gz 18811 BLAKE2B b1389dbe0c6fd855cafc8d64a9db550866317172909c2731f01acd412c6f8147f07e19a82d527187d0b211fca9eb2f2ad63bb53e8f375b0b8107c4e723710000 SHA512 6a88f6f877f49ea8736aeca60673a19c52d5104ad9e2a3e56db3f71cd557d39df9c709c4e678ccf10263ff1f3e0504f4676227bd05ceba1e0294453a988a736c
DIST ppx_tools-6.4.tar.gz 19051 BLAKE2B dcb3e5a4ca5dd6243cae013739b93c6fe100ca21ad56c46e284255977f4e6d4263ef8d937ed672939e5b31bbe0904dcb1d71105f49385ad5d43404b19a9fe2c6 SHA512 514aa283f6bee11bf257abec98a751c656db63203caa4caee5ce606bcdee75891441a794b0bac22e2ff2e5d2760cd39ffaa2fce6bb118155daf05175917e6e7c
+DIST ppx_tools-6.5.tar.gz 19200 BLAKE2B 5cc847fcde8610ad37dbc7884e38869123a59d81549a2ae9e4e2b2a5525cff36fe3e1a31375090dff9b5179b0e12e46d25d54f3a4cefab8cb42de08bb4347691 SHA512 1dc3f62307690161fc7d9f54715918341429bbe13dd68744e9468b41ab7c15ec95cb865135d11c3e3edc6cfb02658b0c731ce1e7756267cf71143ea8e88318fe
diff --git a/dev-ml/ppx_tools/ppx_tools-6.3.ebuild b/dev-ml/ppx_tools/ppx_tools-6.3.ebuild
index fa8079b62de1..146dc4cea675 100644
--- a/dev-ml/ppx_tools/ppx_tools-6.3.ebuild
+++ b/dev-ml/ppx_tools/ppx_tools-6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,4 +16,7 @@ SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
IUSE="+ocamlopt"
-BDEPEND="dev-ml/cppo"
+BDEPEND="
+ dev-ml/cppo
+ <dev-lang/ocaml-4.13.0
+"
diff --git a/dev-ml/ppx_tools/ppx_tools-6.4.ebuild b/dev-ml/ppx_tools/ppx_tools-6.4.ebuild
index b8c31373448b..34cc6727c583 100644
--- a/dev-ml/ppx_tools/ppx_tools-6.4.ebuild
+++ b/dev-ml/ppx_tools/ppx_tools-6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,4 +16,7 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="+ocamlopt"
-BDEPEND="dev-ml/cppo"
+BDEPEND="
+ dev-ml/cppo
+ <dev-lang/ocaml-4.14.0
+"
diff --git a/dev-ml/ppx_tools/ppx_tools-6.5.ebuild b/dev-ml/ppx_tools/ppx_tools-6.5.ebuild
new file mode 100644
index 000000000000..374fa202c924
--- /dev/null
+++ b/dev-ml/ppx_tools/ppx_tools-6.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV=$(ver_rs 2 '+')
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
+SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-$(ver_rs 2 '-')"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/cppo
+"