summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-03 21:38:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-11-03 21:46:00 -0400
commit97005ea03343f6c8f21db00712f8fe7f9288a53d (patch)
tree3e4aaca49e12f3d2956f8d6fadf1a0614c095751
parentgames-action/geki3-KXL: fix build w/ upcoming clang16 (diff)
downloadgentoo-97005ea0.tar.gz
gentoo-97005ea0.tar.bz2
gentoo-97005ea0.zip
games-arcade/xbill: fix build w/ upcoming clang16
Closes: https://bugs.gentoo.org/874624 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-arcade/xbill/files/xbill-2.1-clang16.patch44
-rw-r--r--games-arcade/xbill/xbill-2.1-r5.ebuild (renamed from games-arcade/xbill/xbill-2.1-r4.ebuild)3
2 files changed, 46 insertions, 1 deletions
diff --git a/games-arcade/xbill/files/xbill-2.1-clang16.patch b/games-arcade/xbill/files/xbill-2.1-clang16.patch
new file mode 100644
index 000000000000..ee31ec657e4e
--- /dev/null
+++ b/games-arcade/xbill/files/xbill-2.1-clang16.patch
@@ -0,0 +1,44 @@
+Drop -I. to prevent <strings.h> from including ./strings.h
+https://bugs.gentoo.org/874624
+--- a/Bucket.c
++++ b/Bucket.c
+@@ -1,2 +1,2 @@
+-#include <util.h>
++#include "util.h"
+
+--- a/Game.c
++++ b/Game.c
+@@ -4,2 +4,3 @@
+ #include <string.h>
++#include <strings.h>
+ #include <time.h>
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,3 +22,3 @@
+
+-ALL_CFLAGS = $(CFLAGS) $(CPPFLAGS) -I$(srcdir)
++ALL_CFLAGS = $(CFLAGS) $(CPPFLAGS)
+ ALL_LDFLAGS = $(CFLAGS) $(LDFLAGS)
+--- a/UI.c
++++ b/UI.c
+@@ -3,2 +3,3 @@
+ #include <string.h>
++#include <strings.h>
+
+--- a/gtk.c
++++ b/gtk.c
+@@ -370,3 +370,3 @@
+ gtk_signal_connect_object(GTK_OBJECT(menu_item), "activate",
+- gtk_ui_popup_dialog, (gpointer) dialog);
++ GTK_SIGNAL_FUNC(gtk_ui_popup_dialog), (gpointer) dialog);
+ return (menu_item);
+@@ -592,3 +592,3 @@
+ CreateDialog(DIALOG_PAUSEGAME, 0, icon, "Continue", NULL);
+- CreateEnterText(DIALOG_WARPLEVEL, warp_apply);
++ CreateEnterText(DIALOG_WARPLEVEL, GTK_SIGNAL_FUNC(warp_apply));
+ CreateDialog(DIALOG_HIGHSCORE, 0, NULL, NULL, NULL);
+@@ -602,3 +602,3 @@
+ CreateDialog(DIALOG_ENDGAME, 0, NULL, "Nuts!", NULL);
+- CreateEnterText(DIALOG_ENTERNAME, enter_name);
++ CreateEnterText(DIALOG_ENTERNAME, GTK_SIGNAL_FUNC(enter_name));
+ }
diff --git a/games-arcade/xbill/xbill-2.1-r4.ebuild b/games-arcade/xbill/xbill-2.1-r5.ebuild
index cbd5ae78dd07..2f21efed00bd 100644
--- a/games-arcade/xbill/xbill-2.1-r4.ebuild
+++ b/games-arcade/xbill/xbill-2.1-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-gtk2.patch
"${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {