summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-20 07:23:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-20 09:29:12 +0100
commit971c6c67cc3b663858089a236be54fd38d87857d (patch)
tree0ec1ecc09aef1a9746ab56791d91548895b07284
parentapp-admin/awscli: Bump to 1.32.4 (diff)
downloadgentoo-971c6c67cc3b663858089a236be54fd38d87857d.tar.gz
gentoo-971c6c67cc3b663858089a236be54fd38d87857d.tar.bz2
gentoo-971c6c67cc3b663858089a236be54fd38d87857d.zip
dev-python/trimesh: Bump to 4.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.0.7.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index dbeddbcf2aec..bde62ac3f5a5 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-4.0.5.gh.tar.gz 13433920 BLAKE2B d7979727f4595dedd4d58bd7373bff457e008ea9512fb5aaa3c0e297fb0e9e538ab3b62e6d231bb6d0d7c8499e346c88b89878489187248bfd77116b4ab733dd SHA512 5167f93aece58d0fd2766a41afb5651df2ffac6486e3aebae33d97ed1ae2e4093290450b1e8d7827c300c679cf4c93baf7ce44ec603103a70c510259f514d321
DIST trimesh-4.0.6.gh.tar.gz 13434966 BLAKE2B ddb83647ffb9e268060662c2498bfe3abef423ea8fff6fb0a3d8f2677ff74222f008ca983363a16dbb833c357c8b16f3e92a6968dc79aed5593ee24e23dea076 SHA512 1b6d6be5782a44f58d16060247fe7842a30458fb5b1a01702ee224cd56a4bb3710954166373ec209de960ad6a77a649c44f51a59d31806a034bc6e7d8dca9319
+DIST trimesh-4.0.7.gh.tar.gz 13435408 BLAKE2B 72c9bf419e8a2e74f80922cba41cd999b6245e2376b38034b31d3741b9c9095ad578b46a45f02986f4735fc31086751f6eff1ac49f22af50c7061bf815550e62 SHA512 fcbc6cd917d1b6d0d23064efe6c484c8f920e966c9108cc9664cea502d43abc4cd3fb77cdd54491bb3098efae964910a9fb211aef763f576cf0ab1ae1267f657
diff --git a/dev-python/trimesh/trimesh-4.0.7.ebuild b/dev-python/trimesh/trimesh-4.0.7.ebuild
new file mode 100644
index 000000000000..4a40c4a6730c
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.0.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout --timeout=900
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}