summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-21 20:59:10 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-22 20:18:04 +0200
commit972c3f3e3d611a70add996207149cfd3a4c3a306 (patch)
treeb64ef055a34cc79751982a672d912720b6b26d8b
parentdev-python/ijson: bump to python 3.10 (diff)
downloadgentoo-972c3f3e3d611a70add996207149cfd3a4c3a306.tar.gz
gentoo-972c3f3e3d611a70add996207149cfd3a4c3a306.tar.bz2
gentoo-972c3f3e3d611a70add996207149cfd3a4c3a306.zip
dev-python/multidict: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/multidict/multidict-5.1.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/multidict/multidict-5.1.0.ebuild b/dev-python/multidict/multidict-5.1.0.ebuild
index 4de34908431a..f7429c25891e 100644
--- a/dev-python/multidict/multidict-5.1.0.ebuild
+++ b/dev-python/multidict/multidict-5.1.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -14,9 +15,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-BDEPEND="
- >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]
-"
+BDEPEND=">=dev-python/cython-0.28.4[${PYTHON_USEDEP}]"
distutils_enable_sphinx docs --no-autodoc
distutils_enable_tests pytest