summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-08-26 17:30:24 -0700
committerZac Medico <zmedico@gentoo.org>2022-08-26 17:30:28 -0700
commit9731ec8463a6e816cbc0e00349d462d6921c0790 (patch)
treee10d8f68e59634c5744ceb81f61cc11d7496af25
parentapp-containers/snapd: add 2.57.1 (diff)
downloadgentoo-9731ec84.tar.gz
gentoo-9731ec84.tar.bz2
gentoo-9731ec84.zip
app-containers/buildah: add 1.27.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.27.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index c8c3c02f1bdb..4fe05d4c0e25 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -3,3 +3,4 @@ DIST buildah-1.26.1.tar.gz 14159554 BLAKE2B bf17a51653bb07591c19fca449d6f4eeb876
DIST buildah-1.26.2.tar.gz 14155439 BLAKE2B 3f858f86221b64623d94783c0ef3dd15fa14cef730b30cc5f0554e37f9e3e609a6381842b90b7614b6708434ee5c109497ee89f2da89bb9cc5360e2f8b345adb SHA512 f50a7ee787d10a8f8d1a7e0ff9f86990de975df427af894be5bcc84bceafd2eb87dfe75c1b967ae57056299893c942df257aef1e9aaeb712022a8abceeaebba9
DIST buildah-1.26.3.tar.gz 14468210 BLAKE2B 1ec44501e63bf3594c72575d7460c6478a9d996977659b9fb466fbc658e4923892a77bea9f48a503f02a6101615be9a663f9701ee343436d140d580d8ab01875 SHA512 5d8ea60246085ba27795b52152765fc3c85c92c5caf4515c1b2973aec17844eb9da2ffff82f6c503e36f675089c998b9ee51c4b4b899104ccd9fa771308c8048
DIST buildah-1.26.4.tar.gz 14471666 BLAKE2B ddedadc8f5eac161bc98ab2460abf356ebef9d09bffb1e681db822ed273d9e424e1d638171fcff667efd956e415f988668e6d9fdb3d15db6ed900441c40736eb SHA512 39425ee3f40f1cfd2c76749b43f07efe19c90dff56d9b2024a69e092a328cf526f6bbb23b6f38536e7df11a465219f8f344aa643a82f6511fbb0253e5729d71a
+DIST buildah-1.27.0.tar.gz 14821814 BLAKE2B e9d1ffc05024c3ae520e6436372a9eb592111c0e634d736853f7c84b225ad5e2ebf1a1d5de799a77828cc348a2b82d9fd17e720b149b55966172481155c3c6ae SHA512 7324c85b6f5169522f0cde2cbd0d55b61a2e2fc53d7f03f24ecf606fb564ee6da82cadc493520b4105501124c6c8a1e03aa67b56fb32570f303e849630286afe
diff --git a/app-containers/buildah/buildah-1.27.0.ebuild b/app-containers/buildah/buildah-1.27.0.ebuild
new file mode 100644
index 000000000000..76b4d6de3789
--- /dev/null
+++ b/app-containers/buildah/buildah-1.27.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+GIT_COMMIT=db8d5921
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}