summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:47:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:47 +0100
commit973b09bf9f7bb37c31bdf74437ce9b3faa029e2f (patch)
tree6c6b53d98ebdb3a84cfc820f211826be8b953b4b
parentdev-python/django-otp: Migrate to PEP517 build (diff)
downloadgentoo-973b09bf.tar.gz
gentoo-973b09bf.tar.bz2
gentoo-973b09bf.zip
dev-python/djangorestframework: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/djangorestframework/Manifest2
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.12.4.ebuild41
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.13.0.ebuild32
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 66fbe9674dbb..69164de0ad15 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1 @@
-DIST django-rest-framework-3.12.4.gh.tar.gz 8856507 BLAKE2B 48150e8d966ddd169a2b58d90656efa8f9f549c9d2fdee6025254fba2a6221704fe6bcb246567c8acb963f76ea56046935d3190c7c391daf4773b100a641ba02 SHA512 406b5354809b94e371a2c7d4b62ce66c18a1f60bd02574cba603ad4c44faa4297bdbbd6ee50de63fe21d2aae18386e05d46983a506bddd17f06ce610d5b727c9
-DIST django-rest-framework-3.13.0.gh.tar.gz 8880253 BLAKE2B 8acd6bf386ef20302c8fe52b3a5f1926c03701b32b8c409d13771d632a62e0e01bd8c2efde079e923342a08e6a3d21b3ab13a66817567fe2372f7b8e63eee61a SHA512 2368f382e6dd01490366443ad944f4a48ebbc4928ed45ff58c77a63deb251b148b9e4b13d89b0d2e27a8e257239d75f58f91a11604402683c1c36fac8ce27acc
DIST django-rest-framework-3.13.1.gh.tar.gz 8868916 BLAKE2B 01a2e1c2459f99b1d3b38b62b305a57f3a3358d34a352ef2bbeb6b130c98f19fbbb83325d1013c28107f267a0a0227215646975de54542ab9ca6dfcf2bd88404 SHA512 a272cccf1f19b2cd09ef456a9588fb17ddc56ac3bd735cf7e130d85bb667ca87361d7de26c95b58a05d8cf693ab19c09d913b457f17ad63053ff9b516c13ec9b
diff --git a/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild b/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
deleted file mode 100644
index 8b6cfef95bea..000000000000
--- a/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_P=django-rest-framework-${PV}
-DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org/"
-SRC_URI="
- https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/coreschema[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO
- tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
- # django version incompatibility?
- tests/test_fields.py::TestNaiveDayLightSavingTimeTimeZoneDateTimeField::test_invalid_inputs
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/djangorestframework/djangorestframework-3.13.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.13.0.ebuild
deleted file mode 100644
index db2bbeb43bbe..000000000000
--- a/dev-python/djangorestframework/djangorestframework-3.13.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_P=django-rest-framework-${PV}
-DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org/"
-SRC_URI="
- https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/django-2.2[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/coreschema[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest