summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Kenzelmann <gentoo@k8n.de>2020-09-29 21:02:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-08 13:02:29 +0300
commit973c93c87d5638c4b86c4795cbfe39d06fd39664 (patch)
tree2a2ae7c716905f7a8cad4f9d8c5d90593231627e
parentnet-dns/knot: Updated version to 3.0.0. (diff)
downloadgentoo-973c93c8.tar.gz
gentoo-973c93c8.tar.bz2
gentoo-973c93c8.zip
dev-libs/pigpio: new version 78
Signed-off-by: Daniel Kenzelmann <gentoo@k8n.de> Closes: https://github.com/gentoo/gentoo/pull/17714 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/pigpio/Manifest1
-rw-r--r--dev-libs/pigpio/pigpio-78.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/pigpio/Manifest b/dev-libs/pigpio/Manifest
index c743b666335a..9f57e0c9b368 100644
--- a/dev-libs/pigpio/Manifest
+++ b/dev-libs/pigpio/Manifest
@@ -1,2 +1,3 @@
DIST pigpio-76.tar.gz 2905839 BLAKE2B 7828a94fad9f110392dc114534a3b242f1f135d352885f3c4332a1d4a16f49d2fa58b57e9e3d64c2bf9b5f3bdd7e84a74775b518fc409daf75a55a87c5f3af57 SHA512 8cc1dc64ae32a07f4b6e200638065ba5fb26a94c1a730d81b64fa5f2bb9356b2b9910decb41def6932fc76f7ebd1df99a7966516ba3df9a09108de0afcd119d3
DIST pigpio-77.tar.gz 2902866 BLAKE2B d03a97a596d5f408d29e61e8c5f727d7bca4caf8aeec63e9914b8d52bdc0d03d3d5b9ef1fdb408a6fcd72cd0b899f30eb79d02426cc83b271d71b543bf346928 SHA512 0533d18bc244d4cf487ffebdd68b9f341139e70df3a3862dc4705afefa2e3e4e2f51792a6c4a440b8ee1f111c9ae3141770b9578601bfa44e166bb438f45b80c
+DIST pigpio-78.tar.gz 2900959 BLAKE2B 71a7ed89b247292718229955bf69bec1b7798040fb69b3d9d19a1143cd4fc6565b61deb6ed3bc40eb643a7987f88809125b4368b80aab2fe03bfbaa5fd665274 SHA512 893eefc4a5ab054d56df2c439539ab32a292050aa1fe4b062ba535921f1b12aeac9d509756d08986cd18ed512f52517fa64822422ea3f4dbf6e41fd364a75c3f
diff --git a/dev-libs/pigpio/pigpio-78.ebuild b/dev-libs/pigpio/pigpio-78.ebuild
new file mode 100644
index 000000000000..a47a53d9b909
--- /dev/null
+++ b/dev-libs/pigpio/pigpio-78.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 systemd toolchain-funcs
+
+DESCRIPTION="A library for the Raspberry which allows control of the GPIOs"
+HOMEPAGE="http://abyz.me.uk/rpi/pigpio/ https://github.com/joan2937/pigpio"
+SRC_URI="https://github.com/joan2937/pigpio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=( "${FILESDIR}/${PN}-70-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=: STRIPLIB=: SIZE=:
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: PYTHON2=: PYTHON3=: \
+ libdir="${EPREFIX}/usr/$(get_libdir)" prefix="${EPREFIX}/usr" \
+ mandir="${EPREFIX}/usr/share/man" install
+ einstalldocs
+ newinitd "${FILESDIR}"/pigpiod.initd pigpiod
+ newconfd "${FILESDIR}"/pigpiod.confd pigpiod
+ systemd_newunit "${S}"/util/pigpiod.service pigpiod.service
+ use python && distutils-r1_src_install
+}