summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-15 15:59:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-15 18:05:51 +0100
commit977fd082a670b78b7c2291a100ac683a442c926b (patch)
tree1c3e7a80f27ccb737668d5e6be09ba582a69057e
parentoffice-ext-r1.eclass: Switch echo to einfo, add missing || die (diff)
downloadgentoo-977fd082a670b78b7c2291a100ac683a442c926b.tar.gz
gentoo-977fd082a670b78b7c2291a100ac683a442c926b.tar.bz2
gentoo-977fd082a670b78b7c2291a100ac683a442c926b.zip
app-misc/hivex: Remove old (drop to ~arch)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-misc/hivex/Manifest1
-rw-r--r--app-misc/hivex/hivex-1.3.14.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/app-misc/hivex/Manifest b/app-misc/hivex/Manifest
index 933c62f73e32..7af733a86f68 100644
--- a/app-misc/hivex/Manifest
+++ b/app-misc/hivex/Manifest
@@ -1,2 +1 @@
-DIST hivex-1.3.14.tar.gz 1332257 BLAKE2B fe7c19e05d29c7e98a334842cc1144aa76b148a3b7aae91449a4923a124eb54227a9a004346ef3558732c688c4f92cacd0c9328056930c33dba0404465634da0 SHA512 dd7dd52dceda580179a815fc48a2a2c7e8f7234614beceb937fba7e317df17984e65453338160c4c467b70d7d4f9bd61b48aad3ca51e19bd5e4cfbca8ee3adb6
DIST hivex-1.3.18.tar.gz 1542133 BLAKE2B 961d0797770a2bd3176ce288a509fab8685de91317d55f05e5295f9f56fd54c31acb64847e0cbb6a6074627ccbdfdf35bd0d35150beb7746a8b3de9128ac24e3 SHA512 1851351118921e81df9e505f90d00048a178572c2edd3de40194a69915176bdb615e2eb5afea408d57063e98257c8d1e3d0cd6730407153892cc9e3befc4aa3a
diff --git a/app-misc/hivex/hivex-1.3.14.ebuild b/app-misc/hivex/hivex-1.3.14.ebuild
deleted file mode 100644
index cd4e1de9670b..000000000000
--- a/app-misc/hivex/hivex-1.3.14.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-RUBY_OPTIONAL=yes
-
-PYTHON_COMPAT=(python3_6)
-
-inherit eutils perl-module ruby-ng python-single-r1
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="ocaml readline +perl python test ruby"
-
-RDEPEND="
- virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline:0 )
- perl? (
- dev-lang/perl:=
- dev-perl/IO-stringy
- )
- ruby? ( $(ruby_implementations_depend) )
- python? ( ${PYTHON_DEPS} )
- "
-
-DEPEND="${RDEPEND}
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- "
-
-ruby_add_bdepend "ruby? ( dev-ruby/rake
- virtual/rubygems
- dev-ruby/rdoc )"
-ruby_add_rdepend "ruby? ( virtual/rubygems )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
- ruby? ( || ( $(ruby_get_use_targets) ) )"
-
-DOCS=( README )
-
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- if use python; then
- python-single-r1_pkg_setup
- fi
-}
-
-src_unpack() {
- default
- cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- if use perl; then
- pushd perl
- perl-module_src_configure
- popd
- fi
-
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- --disable-ruby
- $(use_enable python)
- --disable-rpath
- --disable-static
- )
-
- econf ${myeconfargs[@]}
-}
-
-src_compile() {
- default
- ruby-ng_src_compile
-}
-
-src_install() {
- strip-linguas -i po
-
- emake install DESTDIR="${ED}" "LINGUAS=""${LINGUAS}"""
-
- ruby-ng_src_install
-
- if use perl; then
- perl_delete_localpod
- fi
-
- find "${ED}" -name '*.la' -delete || die
-}