summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-05-11 10:55:33 -0300
committerMatt Turner <mattst88@gentoo.org>2023-05-11 10:17:26 -0400
commit978d2020310150a22a632d99f65b2ae70203b77e (patch)
treefef54e267c7e0e40bdb4bec146af7e489f2a3ac4
parentsys-apps/ack: Version bump for 3.7.0; drop 3.5.0 (diff)
downloadgentoo-978d2020310150a22a632d99f65b2ae70203b77e.tar.gz
gentoo-978d2020310150a22a632d99f65b2ae70203b77e.tar.bz2
gentoo-978d2020310150a22a632d99f65b2ae70203b77e.zip
app-accessibility/at-spi2-core: Version bump to 2.48.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30990 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.48.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index f9eb10063d6c..d41c0b55d1a0 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.46.0.tar.xz 540600 BLAKE2B e3ed9915c39a9f71b64a9753c7f91208d15289fe09a9505b4766df7fa04c3e6e5cdc7b3702315eabbdf70f9fc08b4cca4546353485328ab101e2950a672885d6 SHA512 633af2c02fab3b8cb02e37f929ce80dd5ce28ca5641046ef5e25cb29299530b90028e6c6f318a0c098a4270bed3eab48fb55d6967a76bfadd2520f49de47c770
DIST at-spi2-core-2.48.0.tar.xz 554000 BLAKE2B b8f513256670d24ae9f08572ae7878f109b5d76090fa4f881b67324d1d270889c648e456fe3ca34aaead9e85589f5ae355c8b4803f35c2cb2ace831051b1000b SHA512 976dce741d640c5b5e006eca53170062ebc91cace0fb74df68606c8443b63317fe271d4e3238d1e3ee3e5586b4a4905c91d7987adb94c8f886a1aaddd54c632e
+DIST at-spi2-core-2.48.1.tar.xz 554220 BLAKE2B 80c67221d1164ed857586450083ed08c201044cf26c7e338b474344c8579d91bb8310746fa57e01c3c41331647c36b17161d2f1ffda750f5484df0837569398b SHA512 31314322287f73a60ec449896d5bdacb7956e14e5baec1634b34685e340ce5c3d0385023350cc31b316886b24fd1af858656dbdc9119a53c880d85761d15a3c1
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.48.1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.48.1.ebuild
new file mode 100644
index 000000000000..0ec5d49b8cfa
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.48.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility https://gitlab.gnome.org/GNOME/at-spi2-core"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+REQUIRED_USE="gtk-doc? ( X )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.67.4:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+
+ !<dev-libs/atk-2.46.0
+ !<app-accessibility/at-spi2-atk-2.46.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-python/sphinx
+ dev-util/gdbus-codegen
+ >=dev-util/gi-docgen-2021.1
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ $(meson_native_use_feature introspection)
+ $(meson_feature X x11)
+ -Ddisable_p2p=false
+ -Datk_only=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/{libatspi,atk} || die
+ mv "${ED}"/usr/share/doc/libatspi "${ED}"/usr/share/gtk-doc/libatspi/html || die
+ mv "${ED}"/usr/share/doc/atk "${ED}"/usr/share/gtk-doc/atk/html || die
+ fi
+}