summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-06 20:49:51 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-06 21:05:30 +0200
commit97951e3b338d090e9fbf6a8146efe133ec2530f7 (patch)
tree85b17114a3df42aeb6f354faeb5e85ce02caf52e
parentdev-util/bcc: Revbump, rename "trace" tool (bug #828438) (diff)
downloadgentoo-97951e3b.tar.gz
gentoo-97951e3b.tar.bz2
gentoo-97951e3b.zip
dev-python/sphinx-autodoc-typehints: add 1.14.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index a66eb24f1dc3..d940a4adf35a 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,3 +1,4 @@
DIST sphinx-autodoc-typehints-1.12.0.tar.gz 19494 BLAKE2B beacc4f8ab453612dfd5264f1c65fd6bdd957269a28ee5b71b762d0baf5a3d4be58398b32d4263f996648281c1139f47a7564e8fc6444a94095f6a970b4cc27a SHA512 92fa340495a48111fa3d600d8c46d83214505ac2a5c71cb1303e846ac439f1e0ff14f8ce8dfd5ffdb6a62a9fa15dde8a5227f946840d9377ad5f7fde25894b75
DIST sphinx-autodoc-typehints-1.13.0.gh.tar.gz 19898 BLAKE2B a927802a9daec5a2755c06a974aaea30fa92dfd16712d705c9ecb1c9a7b15d5285ade1d8e83d20e9220823500e0257e278b7e48942d9ee6cafdbc36793e9698f SHA512 cc2f91da6b76eb4ccd7579ce27c4d8f2117707b253bd2246711a5179faecc61c4873b3a5e8c1346e03d1db4c59ae76bea0160f34c66f1a0c2dbba1ac2a8086a1
DIST sphinx-autodoc-typehints-1.13.1.gh.tar.gz 19923 BLAKE2B d0f72b814c83dd8987b80bdbaffbab5c3a7c671d9e56e9bb62d3cf44dec1df7b5fb9c591928b89680427069ce8d5953f4dea52de9eb4a4add07a332be96c730a SHA512 50e2958aafaa661cb209da04bb456dadddc4782dd2168c3f6524fba26d906479c66e5b22b3f49fff0c4022acb4b5b99ff73b250cb3e4d5dd9f083c4a5ab12531
+DIST sphinx-autodoc-typehints-1.14.0.gh.tar.gz 21541 BLAKE2B 77b0e80e5518d64be9dde3d3d2af3d9e0e325daa6683ce8aabe6ac88373ee76e11273b98cf3a18c1391a451354b9cec164c8c14e81354092181b959223500669 SHA512 eba927531b074edd1bf4ce0f3e5af53b07d1be3f013b5f39babc81101b32a942040f7b72380f9f485a99bdb8bfec69f7f81d50b0ceaf73b2859f292e47416d59
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild
new file mode 100644
index 000000000000..2791bdf02bb4
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-python/sphinx-4[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}