summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-07 08:30:29 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-07 08:30:41 +0200
commit97f1d928454cfbed8699419e761315a7a26025a2 (patch)
tree611e85b52dcebcdadb64c4d6e8f5a4d30fc2def7
parentdev-ruby/jwt: drop 2.2.3 (diff)
downloadgentoo-97f1d928454cfbed8699419e761315a7a26025a2.tar.gz
gentoo-97f1d928454cfbed8699419e761315a7a26025a2.tar.bz2
gentoo-97f1d928454cfbed8699419e761315a7a26025a2.zip
dev-ruby/net-http-digest_auth: update EAPI 7 -> 8, add ruby32
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r2.ebuild b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..98aaa02d1b34
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An implementation of RFC 2617 - Digest Access Authentication"
+HOMEPAGE="https://github.com/drbrain/net-http-digest_auth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}