summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-12-01 16:04:32 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-02 22:41:16 +0100
commit98099e7d9c7ab2f6cf571f2f8f6d76144f91fe21 (patch)
tree0599cfdb8d9205e251ebfd4316f6acfed20f7963
parentkernel-2.eclass: Minor cleanup. Remove die from global scope per EAPI 6 rules. (diff)
downloadgentoo-98099e7d.tar.gz
gentoo-98099e7d.tar.bz2
gentoo-98099e7d.zip
dev-python/irc: version bump to 15.0.5.
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2970 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-15.0.5.ebuild61
-rw-r--r--dev-python/irc/metadata.xml1
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index 3860d724eed0..7b80b75e5ff5 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1,3 +1,4 @@
DIST irc-11.0.1.zip 120409 SHA256 25d818003780fd6d62e93d3ff32580e74c0e527c6290ae14b47af50b58339233 SHA512 fca2fe653d921c9ec65dfb2b072c16658d88d4a22ae91568b1eaf722a90179920808db157f587afe6de0055af3a04a528eb9022122e539150e5635f05b58f466 WHIRLPOOL dd9b9e8624e6bd86d27fead1f3006a2b80832d236ad21f50c147c07a27b2cc4933d68efd951dece44398dbc0299b73ba7a98e4eff2061d0e3a8a01833518113b
DIST irc-14.2.2.tar.gz 86511 SHA256 4844413b09c8bba226bb86c7269b07ea6c925ecfc5a98758e72849e90895d828 SHA512 daa5f6ed2a5b3f0bdbd58f638d1f90a8b06769c9b7874c577cdb0753aea4a7947c82857aa1ebe6b396ea605756fa176bcca4a9d8e4bf28ef53609f96fccd0e7b WHIRLPOOL 85609370a800b82d59c46595eb5f18dcd33936469cd10692f13a6e2a519406e3725239fbddb5dc0f8d20ad7ab0c6bdb7c8770a9b5f44a86e67c430b3e5287710
DIST irc-15.0.2.tar.gz 81790 SHA256 23893c1fb21826fd9b3edf6ef49b0e1080c846761900ab06b4f1980f5cb8e2e3 SHA512 5f6daa539a9ae665b0153d97ab11f246040963d9109d84efde0a92cbe200c2a6e8126120eee11b4bc92d65d415946627116b62cde07bebeb68a7105af40f98ab WHIRLPOOL 1f28b3e343328a2c78af406944fcfac4be25a61834e1807d7a1636834a2ea9fa9775856380e8ea75df7917913756a4b971e76ab47a06e0379304dfd2e5d81e61
+DIST irc-15.0.5.tar.gz 82138 SHA256 f4ac9678e7e9b451d7852dd67ee216ca9debec7004b16c9708e83137142b30cf SHA512 d9e5eadd02aba00262fee5fc67d52e1caebfcf715466bc104df76e5deee5559692436517b21c08918cb41fbf172bb81c11147f86c488da3441a72efd2c6832b9 WHIRLPOOL 85f5c479c6047e1cb85056489aee0e5e96148865a34a6c31bf8aeddd16ed7f07328efe53bd44327be8f74bc913d039472c01ea922d81e1447194643103a0d348
diff --git a/dev-python/irc/irc-15.0.5.ebuild b/dev-python/irc/irc-15.0.5.ebuild
new file mode 100644
index 000000000000..d6e299a27cdf
--- /dev/null
+++ b/dev-python/irc/irc-15.0.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="https://github.com/jaraco/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
+ dev-python/jaraco-logging[${PYTHON_USEDEP}]
+ dev-python/jaraco-stream[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ doins -r scripts
+ fi
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/irc/metadata.xml b/dev-python/irc/metadata.xml
index 45e8bc4e5e39..f4d5c71852d1 100644
--- a/dev-python/irc/metadata.xml
+++ b/dev-python/irc/metadata.xml
@@ -17,5 +17,6 @@
<remote-id type="pypi">irc</remote-id>
<remote-id type="github">jaraco/irc</remote-id>
<bugs-to>https://github.com/jaraco/irc/issues</bugs-to>
+ <changelog>https://github.com/jaraco/irc/blob/master/CHANGES.rst</changelog>
</upstream>
</pkgmetadata>