summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-12-01 19:34:30 +0100
committerUlrich Müller <ulm@gentoo.org>2022-12-01 19:36:43 +0100
commit981f97a69b0de7e20c5df196e18379702bfaf8ad (patch)
tree0938831afd2e7ebaafef2af1ea347c49abb94946
parentapp-emacs/ebuild-mode: drop 1.56 (diff)
downloadgentoo-981f97a6.tar.gz
gentoo-981f97a6.tar.bz2
gentoo-981f97a6.zip
app-xemacs/ebuild-mode: add 1.61
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.61.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index a29d4adcba70..bb4fafc460af 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.56.tar.xz 36448 BLAKE2B 9126dd5d004a5818a5214f10c88db84faee3945ac25ee141a577a868bf7f127490ee34d6ea103fb788f96c391eea3d00d18abe12564a2f6c70650fc8fe9c6cdf SHA512 2b67208d9f553a322761dc9b64e7b891722c2099cc7c9bfc929e1a424b22ec32c594e0ba029554434b51ef233d2d4435b6c639b06c25fd551608fe5dd830cb03
DIST ebuild-mode-1.60.tar.xz 36996 BLAKE2B a566c9f602ec6ac4126a4a13610e515faf2a02b8ca89f417a037a28f4b9ea633518d589d78f6deb54084be34cdc30c2a1896546b2f86c1166cedd47289edcfd8 SHA512 b04b37b7a376dc48a7f80ec0e60bf36a8b7ea92edcbdd45fbd002e80e8ea29111905a726177a869d607adffe78094efcdc94b1aad32afe1444a09b4e714dcecd
+DIST ebuild-mode-1.61.tar.xz 38632 BLAKE2B f13f251918cf13533611c4d98a9aeceff10e9253c207a10c047c59952d6c8e50cdddb7c3ff65ed7b9565bd09fb45203c9cb57a277165b9cc7bbb47c5d8978a59 SHA512 a7087894299c3882ff0993a1a33cd192ebec078e7cea2f8964610d758a439350dcf36fe43aa43a42b89446d36b62a9b80bfce531e701b0183f3d69e56528ab62
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.61.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.61.ebuild
new file mode 100644
index 000000000000..44559c96c2ab
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.61.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ local XEMACS="${EPREFIX}/usr/bin/xemacs"
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(setq autoload-package-name \"${PN}\")" \
+ -eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
+ -l autoload -f batch-update-autoloads \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}
+
+src_install() {
+ insinto /usr/share/xemacs/site-packages/lisp/${PN}
+ doins *.el *.elc
+}