summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-03-30 16:18:38 -0400
committerRick Farina <zerochaos@gentoo.org>2021-03-30 16:18:38 -0400
commit9820e1418912ba9d7723b9caa66462bfe7396940 (patch)
treec754ea34746be3c6fa143b7f73f6b28874502822
parentnet-libs/libbtbb: migrate off cmake-utils (diff)
downloadgentoo-9820e141.tar.gz
gentoo-9820e141.tar.bz2
gentoo-9820e141.zip
net-libs/libbtbb: drop old
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-libs/libbtbb/Manifest2
-rw-r--r--net-libs/libbtbb/libbtbb-2018.08.1.ebuild150
-rw-r--r--net-libs/libbtbb/libbtbb-2018.12.1.ebuild150
3 files changed, 0 insertions, 302 deletions
diff --git a/net-libs/libbtbb/Manifest b/net-libs/libbtbb/Manifest
index db5113ea61af..512e1bc72a5e 100644
--- a/net-libs/libbtbb/Manifest
+++ b/net-libs/libbtbb/Manifest
@@ -1,3 +1 @@
-DIST libbtbb-2018-08-R1.tar.gz 310542 BLAKE2B 0ae945c530c476caadfd7786f34eca4d7efd71c2f27a37c7b0242a1d3fba80e985c76a0635a354184aa80039ca8ac11f59778f550cbe9bb7e8a535723396cab0 SHA512 63fa995b51f2246b6f27d8aa1bd7a5c0276414df9d13d432d9a1a7ad78ac06e4c67fe3dcf00cf1634f11d6e999f13633591a3347d4e533fff4f131f8deee922e
-DIST libbtbb-2018-12-R1.tar.gz 310437 BLAKE2B 8fec246e05c47df424840f159d97bbb8c6554b2ce72344b63602cb034eb712bf8ee9f280e7bbb5104dc0b9788818ea14cf53d09af0938b1bc1dcede5463b36ce SHA512 5c41bb4f0fdeedc1064de973daa4d396f73ff10b6e28266a43f029cbfa8a7f2db5e3b764410efb50ef79c56ba1fac0d242bb547c0a883d0dc3c06cc9e993332c
DIST libbtbb-2020-12-R1.tar.gz 308434 BLAKE2B 0f802f3c5eef0c434d0468a72104cf63e6bf5f29467e1606d2892751cd8b4824639e3847c0b8305ace926667434e668d75b6d4544e8e026b07872bafbb09c90b SHA512 a3dc2c8d27e4b85aae4847ac39f871ecf800ebf911aacd01682da6c50b13f3247c7d683bce855f2cf59b56a29c661223a2c22e98a8d86e8edaccd57af282bac6
diff --git a/net-libs/libbtbb/libbtbb-2018.08.1.ebuild b/net-libs/libbtbb/libbtbb-2018.08.1.ebuild
deleted file mode 100644
index a1587cd739a2..000000000000
--- a/net-libs/libbtbb/libbtbb-2018.08.1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib cmake-utils
-
-DESCRIPTION="A library to decode Bluetooth baseband packets"
-HOMEPAGE="http://libbtbb.sourceforge.net/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
- inherit git-r3
-else
- MY_PV=${PV/\./-}
- MY_PV=${MY_PV/./-R}
- S=${WORKDIR}/${PN}-${MY_PV}
- SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-IUSE="static-libs wireshark-plugins"
-
-RDEPEND="
- wireshark-plugins? (
- >=net-analyzer/wireshark-1.8.3-r1:=
- )
-"
-DEPEND="${RDEPEND}
- wireshark-plugins? ( dev-libs/glib
- virtual/pkgconfig )"
-
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
-
-which_plugins() {
- if has_version '>=net-analyzer/wireshark-2.2.0'; then
- plugins=""
- elif has_version '>=net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btbredr"
- elif has_version '<net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btle btsm"
- fi
-}
-
-src_prepare() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_prepare
-
- if use wireshark-plugins; then
- which_plugins
- for i in ${plugins}
- do
- sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_prepare
- done
- fi
-}
-
-src_configure() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- local mycmakeargs=(
- -DENABLE_PYTHON=OFF
- -DBUILD_STATIC_LIB=$(usex static-libs)
- -DBUILD_ROOT="${ED}"
- )
- cmake-utils_src_configure
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
- )
- cmake-utils_src_configure
- done
- fi
-}
-
-src_compile() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_compile
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_compile
- done
- fi
-}
-
-src_test() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_test
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_test
- done
- fi
-}
-
-src_install() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_install
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_install
- done
- fi
-}
diff --git a/net-libs/libbtbb/libbtbb-2018.12.1.ebuild b/net-libs/libbtbb/libbtbb-2018.12.1.ebuild
deleted file mode 100644
index d3976d1260b1..000000000000
--- a/net-libs/libbtbb/libbtbb-2018.12.1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib cmake-utils
-
-DESCRIPTION="A library to decode Bluetooth baseband packets"
-HOMEPAGE="http://libbtbb.sourceforge.net/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
- inherit git-r3
-else
- MY_PV=${PV/\./-}
- MY_PV=${MY_PV/./-R}
- S=${WORKDIR}/${PN}-${MY_PV}
- SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
- KEYWORDS="amd64 arm x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-IUSE="static-libs wireshark-plugins"
-
-RDEPEND="
- wireshark-plugins? (
- >=net-analyzer/wireshark-1.8.3-r1:=
- )
-"
-DEPEND="${RDEPEND}
- wireshark-plugins? ( dev-libs/glib
- virtual/pkgconfig )"
-
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
-
-which_plugins() {
- if has_version '>=net-analyzer/wireshark-2.2.0'; then
- plugins=""
- elif has_version '>=net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btbredr"
- elif has_version '<net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btle btsm"
- fi
-}
-
-src_prepare() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_prepare
-
- if use wireshark-plugins; then
- which_plugins
- for i in ${plugins}
- do
- sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_prepare
- done
- fi
-}
-
-src_configure() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- local mycmakeargs=(
- -DENABLE_PYTHON=OFF
- -DBUILD_STATIC_LIB=$(usex static-libs)
- -DBUILD_ROOT="${ED}"
- )
- cmake-utils_src_configure
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
- )
- cmake-utils_src_configure
- done
- fi
-}
-
-src_compile() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_compile
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_compile
- done
- fi
-}
-
-src_test() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_test
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_test
- done
- fi
-}
-
-src_install() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_install
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_install
- done
- fi
-}