summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-12-13 12:59:26 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-12-13 14:07:43 +0100
commit9855db05070c43456ce53123b30503f2bcc5904f (patch)
treeecf3858437ec058e72ae73ac4d5a1fc14ed0dba7
parentdev-python/jaraco-stream: bump to 3.0.0, Python 3.8 support (diff)
downloadgentoo-9855db05070c43456ce53123b30503f2bcc5904f.tar.gz
gentoo-9855db05070c43456ce53123b30503f2bcc5904f.tar.bz2
gentoo-9855db05070c43456ce53123b30503f2bcc5904f.zip
dev-python/jaraco-stream: remove old
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/jaraco-stream/Manifest1
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
index 224403f54db3..b39cc9c57272 100644
--- a/dev-python/jaraco-stream/Manifest
+++ b/dev-python/jaraco-stream/Manifest
@@ -1,4 +1,3 @@
-DIST jaraco.stream-1.1.1.tar.gz 6115 BLAKE2B 0994abe3c9688722c76e656e87166fa60d4bf45fb22ccc826227629bffb60fe0be78bb7a5f9f00b8766b5ce26d641d4b347d6c0fc73c426b424c230cb7d625b6 SHA512 65c8d1652a0d63506cc3cadee590664e6a99e2f770d26f0cea1dce07c54ffe308e1df8619bc728ea81c5ac43c9c6731fe9f71e5d38d2674c4e0d63d635bb5112
DIST jaraco.stream-1.2.tar.gz 7696 BLAKE2B fcc1aa8d26da17635b9ee7c68c278ae572cbe36a108cb30f5eb98c7ebfd2255aad499bed38ea044b28e820646b92e64602db0e2cdfc430169035882f7b6abe9b SHA512 47a96c1de12eb64e250c85d97429218606dc9bb212cf7b97e579763dd901ee063711c00307b7442be400856d3fd4e5994afbe1cb91a99e233541ffd7ff4024b9
DIST jaraco.stream-2.0.tar.gz 11061 BLAKE2B 86cc9958e11421fe839551e029f839c16a12b80d329466b44224d145be6c2a15a63d03f426a9b8d1510249ea6c129e892dcfec41a32dd5c3c3a3b66acc21030f SHA512 d379d07772d739abb275cfc8ed7809583c728af695294b9d12ae1276add360b9559de64104cd20d05d82a3250237ae1f6eb23420970a95e9fdf6346ef9312331
DIST jaraco.stream-3.0.0.tar.gz 11838 BLAKE2B 9d26ff8f78a3f090d79ccc8cbc41819a8290ebdb7770f56a57938ad9311ca1fd168d633fec78ee102c2c08156c9e0ae6f521dd5cafcb9df22928ba9f3f832734 SHA512 f2ce7e65d9a3bcd81985f45d03f7cd56b2f2939f13a423b8b65714f19eb249493d89cad774460dd08c1345124d3d10f85ce6875b5f7049705f993c0a3146e5d9
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
deleted file mode 100644
index edc5fa877577..000000000000
--- a/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Routines for handling streaming data"
-HOMEPAGE="https://github.com/jaraco/jaraco.stream"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/rst-linker[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- # Skip one test which requires network access
- PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}