summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-01-29 21:24:38 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-02-24 15:27:25 +0200
commit98653f7de312b9329894288663afaf72a50109dc (patch)
tree5071a9ab79e894537a068b8079b4025f3f4e872c
parentdev-lang/elixir: add 1.15.7 (diff)
downloadgentoo-98653f7de312b9329894288663afaf72a50109dc.tar.gz
gentoo-98653f7de312b9329894288663afaf72a50109dc.tar.bz2
gentoo-98653f7de312b9329894288663afaf72a50109dc.zip
app-text/cmark: add 0.31.0
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35080 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.31.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index 8ddf9638882f..9405f0d6d887 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1 +1,2 @@
DIST cmark-0.30.3.tar.gz 246916 BLAKE2B b63027e1a7d6db21c3b1bfc89deaebb202972cf65b3ddc51f20d6cb2dacfb6724dffd226f3cace1b25dda2cd87bdb201b82779bd7a6068c5f9751513bda226ae SHA512 27383bfef95ae1390c26aff0dd2cbca33704e7d20116bf29da4695d2c9a4146b86daba0da1e91bdb9eab95671702f885e832b3d31d51601731f1dc630df5237b
+DIST cmark-0.31.0.tar.gz 251922 BLAKE2B 9532255066cd21e99de430787f261b3014c4d270e8243aa258bb9c90cf2ccfd7138dcff2e15f576cc28ee6b6b7901c0f321f5ead6a9202e06b4223288f326897 SHA512 768d456147cb8f5cf36e8122213ad053098201e118109a316518a6a5e721ac94f62af29abe1e69120c84bdc227a5c320803ea2cf320c6d9a719d62909b6533bd
diff --git a/app-text/cmark/cmark-0.31.0.ebuild b/app-text/cmark/cmark-0.31.0.ebuild
new file mode 100644
index 000000000000..80961d0dc538
--- /dev/null
+++ b/app-text/cmark/cmark-0.31.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}