summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-08 21:54:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-08 22:17:53 +0300
commit9877f71fc12aecc10d0d11dfd2a31ce36631e9f5 (patch)
tree15eb4141cb8f832e0b231f5d09c9cb2702093493
parentdev-python/nuitka: drop 0.9.5, 0.9.6, 1.0 (diff)
downloadgentoo-9877f71f.tar.gz
gentoo-9877f71f.tar.bz2
gentoo-9877f71f.zip
dev-python/tomlkit: add 0.11.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 7ab043edb78f..cf3a2f36dbb6 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,2 +1,3 @@
DIST tomlkit-0.11.0.tar.gz 185695 BLAKE2B cd2a22afb8ea445e39567cdc65f636d8d9f2aef07575a2dd989c19abf1a6f7baf2e9adb78003576af9cdefebe4e8c6031efdabcc9487e10770565589a67b0c86 SHA512 2e89748140cfdae217ac3ac999f0b718414d28218d61fb5219adc503ede2ea1f4003be9ef4453f189b0ee86df463c59520244b9fd26553bd4d8047674cba61c9
DIST tomlkit-0.11.1.tar.gz 186422 BLAKE2B 805cf22577a2eb32f4c0183d517886706c23cb925b66a4620d11c4b7f8c6b4314f83403b01d5139695e70e3cb83125923db9e93d651d9bec598fe5fe6ea08038 SHA512 04e8c05ce6ce41a7040fdd02274bebc7ad363f54da9525af06ce39e842d4e7548395dca90a3d1f60956d29d051108719847bebfe6a9db0842a19f400e75481ac
+DIST tomlkit-0.11.2.tar.gz 187584 BLAKE2B 0b18625ab2a1a1caa916961ebedbe943f87a20695b9412ff8d276a39510f897e8df000c45e3b5324e285ce1bf925cb22370e9eef1008639e14f01ce28599692a SHA512 9f8e5f85ae9f408c10a1c64d1ab649db7b42c1b19eb0162a5edcfe894f0a179a0ba39ac7f478eb7bb14267f610169bea1d4e96cde8b9cf62df91218c989d5a2a
diff --git a/dev-python/tomlkit/tomlkit-0.11.2.ebuild b/dev-python/tomlkit/tomlkit-0.11.2.ebuild
new file mode 100644
index 000000000000..8f575bb2866a
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.11.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}