summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-08-12 14:24:47 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-08-12 14:42:19 +0200
commit9880573ac57b2e4197fa3119fac8dd59b7e7025f (patch)
tree94b87b2b04bc3cb517c2c16f6da71c5f50976392
parentdev-python/uranium: treeclean (diff)
downloadgentoo-9880573ac57b2e4197fa3119fac8dd59b7e7025f.tar.gz
gentoo-9880573ac57b2e4197fa3119fac8dd59b7e7025f.tar.bz2
gentoo-9880573ac57b2e4197fa3119fac8dd59b7e7025f.zip
dev-python/pynest2d: treeclean
Closes: https://bugs.gentoo.org/896834 Closes: https://bugs.gentoo.org/905764 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-python/pynest2d/Manifest1
-rw-r--r--dev-python/pynest2d/files/pynest2d-4.12.1-required-flags-from-Libnest2D-target.patch23
-rw-r--r--dev-python/pynest2d/metadata.xml12
-rw-r--r--dev-python/pynest2d/pynest2d-4.13_beta.ebuild39
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/pynest2d/Manifest b/dev-python/pynest2d/Manifest
deleted file mode 100644
index 6e5a58045d41..000000000000
--- a/dev-python/pynest2d/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pynest2d-4.13_beta.tar.gz 18455 BLAKE2B 1c5cbc72d8557f6c8031ea6e5b7e0344c7315dacfe3bf96dc98cd5fc353574811100728f665a27d538c1a9dfb90dce8a7fca477be9f8b589c6174364cc072bfb SHA512 b1918efa18c8d3b641271803ada6fd9122e456181854bb7a62dc574673791ad5a294d239c79cfc4590cb1ef760d410fed5764e81e938df64f5646751746b1250
diff --git a/dev-python/pynest2d/files/pynest2d-4.12.1-required-flags-from-Libnest2D-target.patch b/dev-python/pynest2d/files/pynest2d-4.12.1-required-flags-from-Libnest2D-target.patch
deleted file mode 100644
index ff4482d197bf..000000000000
--- a/dev-python/pynest2d/files/pynest2d-4.12.1-required-flags-from-Libnest2D-target.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -21,11 +21,7 @@
- endif()
-
- find_package(SIP REQUIRED) # To create Python bindings.
--find_package(libnest2d REQUIRED) # The library we're creating bindings for.
--find_package(Clipper REQUIRED) # Dependency of libnest2d.
--find_package(NLopt REQUIRED) # Dependency of libnest2d.
--find_package(Boost REQUIRED) # Dependency of libnest2d.
--set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DLIBNEST2D_GEOMETRIES_clipper -DLIBNEST2D_OPTIMIZERS_nlopt -DLIBNEST2D_THREADING_std") # Tell libnest2d to use Clipper and NLopt, and standard threads.
-+find_package(Libnest2D REQUIRED) # The library we're creating bindings for.
-
- # Some build options.
- set(CMAKE_CXX_STANDARD 17)
-@@ -56,5 +52,5 @@
- )
-
- set(SIP_EXTRA_OPTIONS -g -n PyQt5.sip) # Always release the GIL before calling C++ methods. -n PyQt5.sip is required to not get the PyCapsule error
--include_directories(src/ ${SIP_INCLUDE_DIRS} ${Python3_INCLUDE_DIRS} ${CLIPPER_INCLUDE_DIRS} ${NLopt_INCLUDE_DIRS} ${LIBNEST2D_INCLUDE_DIRS})
--add_sip_python_module(pynest2d src/Pynest2D.sip ${CLIPPER_LIBRARIES} ${NLopt_LIBRARIES})
-+include_directories(src/ ${SIP_INCLUDE_DIRS})
-+add_sip_python_module(pynest2d src/Pynest2D.sip Libnest2D::libnest2d_headeronly)
diff --git a/dev-python/pynest2d/metadata.xml b/dev-python/pynest2d/metadata.xml
deleted file mode 100644
index eba99385dd29..000000000000
--- a/dev-python/pynest2d/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>3dprint@gentoo.org</email>
- <name>Gentoo 3D Printer Project</name>
- </maintainer>
- <upstream>
- <bugs-to>https://github.com/Ultimaker/pynest2d/issues</bugs-to>
- <remote-id type="github">Ultimaker/pynest2d</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pynest2d/pynest2d-4.13_beta.ebuild b/dev-python/pynest2d/pynest2d-4.13_beta.ebuild
deleted file mode 100644
index a4031ec46db2..000000000000
--- a/dev-python/pynest2d/pynest2d-4.13_beta.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PV=$(ver_rs 2 -)
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-single-r1
-
-DESCRIPTION="Python bindings for libnest2d"
-HOMEPAGE="https://github.com/Ultimaker/pynest2d"
-SRC_URI="https://github.com/Ultimaker/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/libnest2d
- $(python_gen_cond_dep '<dev-python/sip-5[${PYTHON_USEDEP}]')
- "
-
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.12.1-required-flags-from-Libnest2D-target.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DPython3_EXECUTABLE="${PYTHON}"
- )
-
- cmake_src_configure
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 646a07cc65bd..83ebec3daa92 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -490,7 +490,6 @@ dev-libs/clipper
dev-libs/libcharon
dev-libs/libnest2d
dev-libs/libsavitar
-dev-python/pynest2d
# Sam James <sam@gentoo.org> (2023-05-03)
# Broken pkgconfig file, please upgrade to -r1.