summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-20 14:14:56 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-20 14:29:28 -0500
commit98986130f44e30e36f9d6f03a4f9d34765891650 (patch)
tree031ae8f9f64b1f4c86938333a2dcf918b3a485d0
parentdev-php/phpdepend: Revbump to fix absolute symlink (diff)
downloadgentoo-98986130f44e30e36f9d6f03a4f9d34765891650.tar.gz
gentoo-98986130f44e30e36f9d6f03a4f9d34765891650.tar.bz2
gentoo-98986130f44e30e36f9d6f03a4f9d34765891650.zip
dev-php/phpmd: Version bump to 2.6.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-php/phpmd/Manifest1
-rw-r--r--dev-php/phpmd/phpmd-2.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/phpmd/Manifest b/dev-php/phpmd/Manifest
index e3cef785a576..c6cfd5cac721 100644
--- a/dev-php/phpmd/Manifest
+++ b/dev-php/phpmd/Manifest
@@ -1 +1,2 @@
DIST phpmd-2.5.0.tar.gz 56360 BLAKE2B 03b515e55babb1e0c6df2573f87fd10ee63f1c17a5e448dc3debd74c07c72b32c0331687fb79f023072e276fe18d9de2476f2b70d3f8bf555f1b133a9751fdcd SHA512 93e5eac4755ce9dbe003935a5768c2798f13c3a40d5a7c188d3a70edc1fe76646b72144a62f943f3fc95f83131f96b315a63e327971c3c4404d600fcd5f43d18
+DIST phpmd-2.6.0.tar.gz 57496 BLAKE2B 447e1b0a18372abc82746e8f2a47ea0df76fdeea51e7012ea63a0d644f7cd71790a3e354584d18f57bab3e7211f1037ff3f61aff367c3419caa44e77e79d1cbb SHA512 7c81bef8457f28dd40b908f535cf432d65ba6910c54f730b4d9f7a0bffa096653af029701a6ce4bd22910ec69453c5ff22c657100757d7d6eacff2226b597023
diff --git a/dev-php/phpmd/phpmd-2.6.0.ebuild b/dev-php/phpmd/phpmd-2.6.0.ebuild
new file mode 100644
index 000000000000..dc08acef5020
--- /dev/null
+++ b/dev-php/phpmd/phpmd-2.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP mess detector"
+HOMEPAGE="http://www.phpmd.org/"
+
+# The test suite is absent from the release tarballs because
+# the only build system that Composer understands is "cp -r".
+# To obtain the tests, we would need to grab a VCS snapshot.
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[xml]
+ dev-php/phpdepend"
+
+src_install() {
+ dodoc AUTHORS.rst CHANGELOG CONTRIBUTING.md README.rst
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ insinto "/usr/share/${PN}/src"
+ doins -r src/main
+
+ # The executable uses relative include paths, so the one users will
+ # actually run needs to be symlinked into the source tree.
+ exeinto "/usr/share/${PN}/src/bin"
+ doexe "src/bin/${PN}"
+ dosym "../share/${PN}/src/bin/${PN}" "/usr/bin/${PN}"
+}